Tried 13.0 dev10_win64 ,won't load extra star catalogs

Bug #1329500 reported by Edkiefer on 2014-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Guillaume Chereau

Bug Description

This only affects 64 build, 32bit works fine .

The star catalogs that give mag11+ don't load even though I have them DL to user folder . I even deleted them and re DL thinking there might be some difference or updates .

here is section of log that shows error .

 -------------------------------------------------------
Writing log file to: "C:\Users\Ed\AppData\Roaming\Stellarium\log.txt"
File search paths:
  0 . "C:\Users\Ed\AppData\Roaming\Stellarium"
  1 . "."
Config file is: "C:\Users\Ed\AppData\Roaming\Stellarium\config.ini"
OpenGL versions supported: "1.1, 1.2, 1.3, 1.4, 1.5, 2.0, 2.1, 3.0, 3.1, 3.2, 3.3, 4.0, 4.1, 4.2, 4.3"
Driver version string: "4.4.0"
GL vendor is "NVIDIA Corporation"
GL renderer is "GeForce GTX 660 Ti/PCIe/SSE2"
Cache directory is: "C:\Users\Ed\AppData\Local\stellarium\stellarium\cache"
Sky language is "en_US"
Application language is "en_US"
Loading Solar System data ...
Loading star data ...
"Loading ".\stars\default\stars_0_0v0_4.cat": 0_0v0_4; 4979"
"Loading ".\stars\default\stars_1_0v0_4.cat": 1_0v0_4; 21800"
"Loading ".\stars\default\stars_2_0v0_4.cat": 2_0v0_4; 150779"
ERROR: SpecialZoneArray( 3 )::SpecialZoneArray: QFile( "./stars/default/stars_3_1v0_3.cat" .map( 5152 , 6855456 ) failed: "Access is denied."
"Loading ".\stars\default\stars_3_1v0_3.cat": 3_1v0_3; - initialization failed"
ERROR: SpecialZoneArray( 4 )::SpecialZoneArray: QFile( "C:/Users/Ed/AppData/Roaming/Stellarium/stars/default/stars_4_1v0_1.cat" .map( 20512 , 27232672 ) failed: "Access is denied."
"Loading "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_4_1v0_1.cat": 4_1v0_3; - initialization failed"
ERROR: SpecialZoneArray( 5 )::SpecialZoneArray: QFile( "C:/Users/Ed/AppData/Roaming/Stellarium/stars/default/stars_5_2v0_1.cat" .map( 81952 , 56664464 ) failed: "Access is denied."
"Loading "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_5_2v0_1.cat": 5_2v0_1; - initialization failed"
Finished loading star catalogue data, max_geodesic_level: 2
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 414 / 414 NGC name records successfully
Loading star names from ".\skycultures\western\star_names.fab"
Loaded 237 / 237 common star names
Loading star names from ".\stars\default\name.fab"
Loaded 4359 / 4359 scientific star names
Loading variable stars from ".\stars\default\gcvs_hip_part.dat"
Loaded 6886 / 6886 variable stars
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Intializing basic GL shaders...

I can give full log if needed but think that shows the issue , again only 64bit build, 32 loads all catalogs w/o errors .

Related branches

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
milestone: none → 0.13.0
tags: added: windows
Changed in stellarium:
status: Confirmed → In Progress
Edkiefer (ekiefer) wrote :

Was the .13 beta1exp-win64.exe build suppose to address this issue?

anyway, it does not even start here at all, no log generated , just pop up with "app failed to start because it could not find QT platform plugin found "

Alexander Wolf (alexwolf) wrote :

It's broken deployment in Qt5.3.1/MSVC2013 :( I'll try fix it.

Edkiefer (ekiefer) wrote :

yes, new packages work as far as starting , but if exp-win64 build still doesn't load stars_3,4 and 5 catalogs .

Loading star data ...
"Loading ".\stars\default\stars_0_0v0_5.cat": 0_0v0_2; 4963"
"Loading ".\stars\default\stars_1_0v0_5.cat": 1_0v0_2; 21598"
"Loading ".\stars\default\stars_2_0v0_5.cat": 2_0v0_2; 150090"
ERROR: SpecialZoneArray( 3 )::SpecialZoneArray: QFile( "./stars/default/stars_3_1v0_3.cat" .map( 5152 , 6855456 ) failed: "Access is denied."
"Loading ".\stars\default\stars_3_1v0_3.cat": 3_1v0_3; - initialization failed"
Found file "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_4_1v0_1.cat" , checking md5sum..
MD5 sum correct!
ERROR: SpecialZoneArray( 4 )::SpecialZoneArray: QFile( "C:/Users/Ed/AppData/Roaming/Stellarium/stars/default/stars_4_1v0_1.cat" .map( 20512 , 27232672 ) failed: "Access is denied."
"Loading "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_4_1v0_1.cat": 4_1v0_3; - initialization failed"
Found file "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_5_2v0_1.cat" , checking md5sum..
MD5 sum correct!
ERROR: SpecialZoneArray( 5 )::SpecialZoneArray: QFile( "C:/Users/Ed/AppData/Roaming/Stellarium/stars/default/stars_5_2v0_1.cat" .map( 81952 , 56664464 ) failed: "Access is denied."
"Loading "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_5_2v0_1.cat": 5_2v0_1; - initialization failed"
Finished loading star catalogue data, max_geodesic_level: 2

Changed in stellarium:
milestone: 0.13.0 → none
status: In Progress → Confirmed
Edkiefer (ekiefer) wrote :

Hi

I noticed now this bug is not listed anymore under 0.13 or 0.13.1 , IS there issue with 64 builds now .

Just asking if it is over-site or if I should switch to 32bit testing and usage .
Not really sure if 64bit is really needed anyway ,think the 32bit would be fine on 64bit OS .

Alexander Wolf (alexwolf) wrote :

This issue related to specific working of MSVC and can be reproduced only on MSVC-build packages. Our 32-bit package has been built by MinGW GCC and it doesn't have this issue.

tags: added: catalog msvc
Edkiefer (ekiefer) wrote :

Just installed 13.0.8 win64 and user catilogs seem to be loading now, no errors with it (I only have 2 user based to 13.5mag stars ) .

Loading Solar System data ...
Loading star data ...
"Loading ".\stars\default\stars_0_0v0_5.cat": 0_0v0_2; 4963"
"Loading ".\stars\default\stars_1_0v0_5.cat": 1_0v0_2; 21598"
"Loading ".\stars\default\stars_2_0v0_5.cat": 2_0v0_2; 150090"
"Loading ".\stars\default\stars_3_1v0_3.cat": 3_1v0_3; 428466"
"Loading "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_4_1v0_1.cat": 4_1v0_3; 1702042"
"Loading "C:\Users\Ed\AppData\Roaming\Stellarium\stars\default\stars_5_2v0_1.cat": 5_2v0_1; 7083058"
Finished loading star catalogue data, max_geodesic_level: 5

Alexander Wolf (alexwolf) wrote :
Changed in stellarium:
milestone: none → 0.13.1
assignee: nobody → Guillaume Chereau (guillaume-chereau)
status: Confirmed → Fix Committed

Yes, there is apparently something wrong with the stars unpacking of the
extra catalogues after my change of using bit operations instead of
bit-fields. I will have a look at this.

OK never mind my last comment, I hadn't seen the other messages in the threads. This is not related to the bitfield issue.

Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers