Huge patch with almost no stars

Bug #1320065 reported by mpopp on 2014-05-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Guillaume Chereau

Bug Description

There is a huge patch with almost no stars to the right of the constellation Crux, see screenshot.

This is on Xubuntu 14.04 inside VirtualBox 4.3.10, running also on Xubuntu 14.04 (all 64bit). I don't have a native Stellarium 0.13 installation yet, so I don't know which role VirtualBox plays, but I thought it's good to let you know.

Stellarium builds are the 14.04 64bit builds from https://code.launchpad.net/~stellarium/+archive/daily as of commit 6797.

mpopp (mpopp75) wrote :
Alexander Wolf (alexwolf) wrote :

It's rendering issue - thanks for report.

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
milestone: none → 0.13.0
Fabien Chéreau (xalioth) wrote :

Could you try to reproduce this outside of virtual box? I don't see an obvious reason for that right now. Maybe a mmap problem as the star catalog is mmapped..

Changed in stellarium:
milestone: 0.13.0 → 0.13.1
mpopp (mpopp75) wrote :

Here is a video of this issue (in Ogg Vorbis format), showing how this starless patch moves as time is being fast forwarded.

It's Stellarium 0.13.0 build 6866 on Linux64 (Xubuntu 14.04 64bit) running inside VirtualBox 4.3.12.

Alexander Wolf (alexwolf) wrote :

Can you check this issue on "hardware"?

mpopp (mpopp75) wrote :

I could reproduce this bug on a native system (without VirtualBox being involved) as well. New video is attached.

It's the same Stellarium build and a fresh profile, again on Xubuntu 14.04 64bit.

Changed in stellarium:
milestone: 0.13.1 → none
Alexander Wolf (alexwolf) wrote :

Fabien, I can reproduce it on hardware. I guess this issue has been introduced after refactoring the feature of rendering the stars.

Changed in stellarium:
assignee: nobody → Fabien Chéreau (xalioth)

Apparently the bug comes from the commit r6320.

In ZoneArray.cpp, line 513, reintroducing:

    if (!cap.contains(vf))

fixes the issue.

Alexander Wolf (alexwolf) wrote :

Thanks for work, Guillaume, but this patch doesn't fix the issue for me. :(

Alexander Wolf (alexwolf) wrote :

Guillaume, seems you are fixed this issue with work on spheric mirror distortion. O_o

Changed in stellarium:
assignee: Fabien Chéreau (xalioth) → Guillaume Chereau (guillaume-chereau)
milestone: none → 0.13.1
status: Confirmed → Fix Committed
mpopp (mpopp75) wrote :

Should this be fixed in builds as of commit 7069? Still seeing the bug there.

Alexander Wolf (alexwolf) wrote :

Are you tried 0.13.0.92?

mpopp (mpopp75) wrote :

Are there Linux builds of 0.13.0.92? I only find Windows + OS X builds at https://launchpad.net/stellarium/+download

I installed build 7069 downloaded at https://code.launchpad.net/~stellarium/+archive/ubuntu/daily

Is 0.13.0.92 newer than build 7069? To me, build 7069 looked newer.

Alexander Wolf (alexwolf) wrote :

0.13.0.92 is 7068. It's odd because I can't reproduce this issue now. I'll check it again tonight.

mpopp (mpopp75) wrote :

Could there be a problem left which is specific to Linux?

Alexander Wolf (alexwolf) wrote :

OK, I can reproduce it on Windows with old Intel GPU

Changed in stellarium:
status: Fix Committed → In Progress
assignee: Guillaume Chereau (guillaume-chereau) → nobody
Alexander Wolf (alexwolf) wrote :

Ouch... I can reproduce it on linux too but only for specific time of the day.

mpopp (mpopp75) wrote :

This spot moves around the Southern celestial pole roughly at about 50° S as you advance in time. See attached video.

I just pushed a change that should probably fix the issue. rev 7070. Let me know if you still have the same problem.

mpopp (mpopp75) wrote :

Awesome, now the problem is gone :).

Thank you very much for the fix!

Alexander Wolf (alexwolf) wrote :
Changed in stellarium:
status: In Progress → Fix Committed
assignee: nobody → Guillaume Chereau (guillaume-chereau)
norbinz (norbinz) wrote :

It's the monolith from 2001 A Space Odyssey.

I too see the problem in 0.13.0 on my Win7 64-bit i7 with GTX 460 and 337.88 driver.
If anyone wishes, I'd be happy to try the fix, if a Windows build is available.

Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers