Night Mode shader

Bug #1263678 reported by Alexander Wolf on 2013-12-23
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Alexander Wolf

Bug Description

Current implementation of Night Mode feature has shaders inside QML scene, who based on QtQuick v1 technology. Qt 5.2 on Windows and OS X doesn't find Qt.labs.shaders and give application's crash or white screen mode.

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Guillaume Chereau (guillaume-chereau)

I don't have my mac with me these days. I will check that next week when I come back from holidays.

I finally tested on my Mac mini, using the last release of Qt (5.2.0)

Here the night mode works, albeit extremely slowly. I get around 2 fps. I am going to make some more tests to find if the problem comes from stellarium or Qt.

treaves (treaves) wrote :

Guillaume, how are you running? On all three of my Mac's, Stellarium is not completely unusable. This is due to the labs.Shaders not being found (unless run from Creator), and a serious bug in QDir (which I can work around). But when run from Creator, the sky is totally broken, and it sig's every time run from the command line.

treaves (treaves) wrote :

This is what I see on my Mac's. Trunk code.

treaves (treaves) wrote :

O.K., my sky issue was that a texture was being expected, and it wasn't there. I've added that, and now the sky is fine.

I still can not run from command line, due to the qml issues.

Alexander Wolf (alexwolf) wrote :

This issue related to wrong deployment QML-stuff on those platforms. For Windows I made a fix, now we should make a fix for OS X.

Diff for Windows:

Alexander Wolf (alexwolf) wrote :
Changed in stellarium:
status: Confirmed → Fix Committed
assignee: Guillaume Chereau (guillaume-chereau) → Alexander Wolf (alexwolf)
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers