Time and date window glitch at boundary datetimes

Bug #1206284 reported by Richard bartosz on 2013-07-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Low
Alexander Wolf
0.14
Low
Alexander Wolf

Bug Description

Experimenting with positions of sky objects between Julian and Gregorian calendars at the October 4/15 1582 changeover, I found that going forwards by "days" from 4 October 1582 was working fine. However, going back the program stalls at 15 October 1582 i.e. it won't proceed any further back. Month and year steps work fine but not days.

The program itself doesn't stall and I can work around the glitch by stepping back a month and then progressing forwards by days.

I reinstalled stellarium-0.12.2dev5-win32.exe, which I was previously using, and found the same glitch.

I am using OS XP-SP3, version 2002, Home Edition.

Richard

Bogdan Marinov (daggerstab) wrote :

It's because of the StelUtils::changeDateTimeForRollover() function - it validates dates submitted by the Date and time window. When it comes to that date, it rounds it "up". There is a similar bug with the day/time of daylight saving time transition and cycling by hour/minute.

Problems like these will be addressed by the time zone code on which I'm working, so I'm assigning this bug to myself.

summary: - stellarium-0.12.2RC3-win32.exe glitch at October 15 1582
+ Time and date window glitch at boundary datetimes
Changed in stellarium:
assignee: nobody → Bogdan Marinov (daggerstab)
importance: Undecided → Low
status: New → Confirmed
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 8385 of the trunk branch of Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/8385

Changed in stellarium:
assignee: Bogdan Marinov (daggerstab) → Alexander Wolf (alexwolf)
milestone: none → 0.15.0
status: Confirmed → Fix Committed
tags: added: time
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers