Setting Startup date and time (Other:) sets time to UTC, not my local (EDT) time

Bug #1198570 reported by Stewart Leabman on 2013-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Medium
Alexander Wolf

Bug Description

Example: I want to set the Startup date and time to 6/21/2013 10:00:00 PM. (To show the ISS going almost overhead) I go to the Date and Time dialog box by clicking on the Date/time Window [F5} on the left menu. I set the time to " 2013 / 6 / 21 | 22 : 0 : 0 " which sets the time to about eleven minutes before the satellite goes above my horizon. Then I go to the Configuration, Navigation window and click on "use current" This sets the date and time in the box to the left of "use current" to 6/22/2013 2:01:00 AM. This is four hours and one minute ahead of the time that I entered. If I then save the settings, close Stellarium, and then reopen it, the startup time is now 6/22/2013 2:01:00AM LOCAL time. Since I am in the Eastern Daylight Time Zone, it appears that the program is setting the time to UT plus one minute. So, I then have to type the correct date and time into the "Other:" box and save it to have Stellarium start up at the correct time.

I was observing the ISS on that date and Stellarium displayed its position dead-on in real-time, so it was correct for my local time.

Feel free to contact me if you have any questions.

Thanks.

Stew Leabman

Related branches

Stewart Leabman (kb3jrb) on 2013-07-07
summary: - Setting Starup date and time (Other:) sets time to UTC, not my local
+ Setting Startup date and time (Other:) sets time to UTC, not my local
(EDT) time
Changed in stellarium:
status: New → Confirmed
importance: Undecided → Medium
Alexander Wolf (alexwolf) wrote :

Button "use current" set current date and time for "Other:" field - it's not wrong. But error around 1 minute is wrong for this field when you press button "use current".

Alexander Wolf (alexwolf) wrote :

Note: phrase "set current date and time" need read as "set current UTC date and time"

Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 6110 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/6110

Changed in stellarium:
milestone: none → 0.12.2
assignee: nobody → Alexander Wolf (alexwolf)
Alexander Wolf (alexwolf) wrote :

Now button 'use current' used local date and time

Changed in stellarium:
status: Confirmed → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers