Indication for azimuth/equatorial mount mode

Bug #1172860 reported by Robert Van Vugt on 2013-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Wishlist
Alexander Wolf

Bug Description

Presently it is hard to tell which mode the equatorial/azimuth mode button is actually set to as the text help just says switch between the two, Wishlist item would be to change text of button to indicate the actual mode that it is set to/in. This would make it more user friendly and easier to use. As it is you really can not tell which mode the mount select button is in.

Tags: gui Edit Tag help

Related branches

description: updated
gzotti (georg-zotti) wrote :

Equatorial mode is active when the equatorially mounted telescope icon is shown bright. Hard to tell?

Robert Van Vugt (rvvcuda) wrote :

Actually Yes it is and that is apparent by you having to explain to me how it works. The icon is displayed on my screen at about 25% the size of a keyboard key - thus not much detail. Then there is the question of is it on or off when selected. This might seem obvious to the engineers and software designers but it is in actuality a bit unclear and it is indeed a small issue for certain but if your aim is to improve the program it would be nice to be able to see some confirmation as to which mode it is in. This was listed as a wishlist item, a suggestion for improvement and not a buggg.

Bogdan Marinov (daggerstab) wrote :

The button's tool tip text is actually the description of the "action" as used in the keyboard shortcuts system, so making it dynamic will be more painful that it's worth.

What you actually want is some kind of clear indication in what mount mode is Stellarium, isn't it? I will change the bug title accordingly.

An example solution would be to have "Equatorioul mount"/"Alt-azimuth mount" flash for a second in the center of the screen on change. Would that be sufficient?

(Note to a certain quick-feature-adder: this is still being discussed. It's still not determined whether this is an issue and whether this is a good solution, so please hold back. In case we decide the solution described by me is the right one: the way of implementation should be carefully thought out, not hastily kludged to the nearest class. It probably should be a part of LabelMgr. We do need some kind of standard interface for displaying messages from the plug-ins and other modules. Oh, and if someone is going to do something about it, please do it in a separate branch, not directly in the trunk.

Changed in stellarium:
importance: Undecided → Wishlist
status: New → Opinion
summary: - Azimuth/Equatorial Button Modification - Wishlist
+ Indication for azimuth/equatorial mount mode
Robert Van Vugt (rvvcuda) wrote :

Yes - That is the idea, Your idea to flash a status on screen for 1 second is just fine, The idea is to have some sort of confirmation of what mode it is in. I like it!

"What you actually want is some kind of clear indication in what mount mode is Stellarium, isn't it? " - YES SIR!

I will change the bug title accordingly. OK

"An example solution would be to have "Equatorioul mount"/"Alt-azimuth mount" flash for a second in the center of the screen on change. Would that be sufficient?" YES GREAT IDEA.

Changed in stellarium:
status: Opinion → Confirmed
tags: added: gui
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 9397 of the trunk branch in Stellarium's Bazaar repository at Launchpad: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/9397

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
milestone: none → 0.16.0
status: Confirmed → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
Robert Van Vugt (rvvcuda) wrote :

Alexander - Nice work! Just installed v16.0 and this works very nicely. Love it! Thanks for adding this minor feature.

Robert

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers