wrong rendering of Planet's shadow

Bug #1131847 reported by Pierluigi Panunzi on 2013-02-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
High
Jörg Müller

Bug Description

with version 0.12.0 the new rendering allows shadow casting of planets on satellites and vice-versa.

Saturn casts a wrong shadow onto the rings: it is smaller than the planet diameter.

this error is visible for example going to the "Solar System Observer" object and zooming to Saturn.
if you set the date to 2016 january 24th you can see Saturn from one Pole and the shadow appears smaller then the planet's diameter.

this is the firs time I post a bug here, so I don't know if I succeed in posting also a snapshot, but it's even unnecessary: the bug is always present...

related to the incorrect rendering of the shadow, are also the wrong timings of ingress ad egress of Jupiter's satellites into the planet's shadow, even setting correctly the "Simulate light speed" option in the "Sky and Viewing Option Window" [F4]
I found discrepancies of even 1 hour for Callisto start time of eclipse, reduced to about 15 minutes for the end time of eclipse, for 2019 november 9th, during one of the rare events in with Jupiter appears moonless, with Europa and Callisto eclipsed and Ganymede and Io in transit.

thanks!

here is my log.txt

2013-02-22T17:47:42
Windows 7
Compiled using MinGW GCC 4.6.1
Qt runtime version: 4.8.2
Qt compilation version: 4.8.2
Addressing mode: 64-bit
Total memory: 4078 MB (unreliable)
Total virtual memory: 8388607 MB (unreliable)
Physical memory in use: 41%
Processor speed: 2793 MHz
Processor name: Intel(R) Core(TM) i5-2300 CPU @ 2.80GHz
Processor speed: 2793 MHz
Processor name: Intel(R) Core(TM) i5-2300 CPU @ 2.80GHz
Processor speed: 2793 MHz
Processor name: Intel(R) Core(TM) i5-2300 CPU @ 2.80GHz
Processor speed: 2793 MHz
Processor name: Intel(R) Core(TM) i5-2300 CPU @ 2.80GHz
C:\Program Files\Stellarium\stellarium.exe
 -------------------------------------------------------
[ This is Stellarium 0.12.0 - http://www.stellarium.org ]
[ Copyright (C) 2000-2013 Fabien Chereau et al ]
 -------------------------------------------------------
Writing log file to: "C:/Users/packard-627009/AppData/Roaming/Stellarium/log.txt"
File search paths:
  0 . "C:\Users\packard-627009\AppData\Roaming\Stellarium"
  1 . "."
Config file is: "C:\Users\packard-627009\AppData\Roaming\Stellarium/config.ini"
Going to initialize the OpenGL 2 renderer
OpenGL supported version: "3.3.0"
Qt GL paint engine is: "OpenGL2"
GL vendor is "NVIDIA Corporation"
GL renderer is "GeForce 405/PCIe/SSE2"
Log of the compilation of builtin shader " plainShader " : "Built successfully"
Log of the compilation of builtin shader " colorShader " : "Built successfully"
Log of the compilation of builtin shader " textureShader " : "Built successfully"
Log of the compilation of builtin shader " colorTextureShader " : "Built successfully"
Cache directory is: "C:\Users\packard-627009\AppData\Local\stellarium\stellarium\cache"
Sky language is "en"
Application language is "en"
Loading Solar System data ...
Loaded 74 / 74 planet orbits from "C:\Users\packard-627009\AppData\Roaming\Stellarium/data/ssystem.ini"
Loading star data ...
"Loading "./stars/default/stars_0_0v0_1.cat": 0_0v0_1; 5013"
"Loading "./stars/default/stars_1_0v0_1.cat": 1_0v0_1; 21999"
"Loading "./stars/default/stars_2_0v0_1.cat": 2_0v0_1; 151416"
"Loading "./stars/default/stars_3_1v0_0.cat": 3_1v0_0; 434064"
"Loading "C:\Users\packard-627009\AppData\Roaming\Stellarium/stars/default/stars_4_1v0_0.cat": 4_1v0_0; 1725497"
"Loading "C:\Users\packard-627009\AppData\Roaming\Stellarium/stars/default/stars_5_2v0_0.cat": 5_2v0_0; 7669011"
"Loading "C:\Users\packard-627009\AppData\Roaming\Stellarium/stars/default/stars_6_2v0_0.cat": 6_2v0_0; 26615233"
"Loading "C:\Users\packard-627009\AppData\Roaming\Stellarium/stars/default/stars_7_2v0_0.cat": 7_2v0_0; 57826266"
"Loading "C:\Users\packard-627009\AppData\Roaming\Stellarium/stars/default/stars_8_2v0_0.cat": 8_2v0_0; 116923084"
Finished loading star catalogue data, max_geodesic_level: 8
navigation/preset_sky_time is a double - treating as jday: 2.45151e+06
Loaded 10051 NGC records
Loading NGC name data ...
Loaded 288 / 288 NGC name records successfully
Loading star names from "./skycultures/western/star_names.fab"
Loaded 230 / 230 common star names
Loading star names from "./stars/default/name.fab"
Loaded 3215 / 4359 scientific star names
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 89 / 89 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Not using any viewport effect
Creating GUI ...
Loading shortcuts...
Loaded plugin "AngleMeasure" .
AngleMeasure plugin - press control-A to toggle angle measure mode
Loaded plugin "CompassMarks" .
CompassMarks plugin - press control-C to toggle compass marks
Loaded plugin "SolarSystemEditor" .
Using the ssystem.ini file that already exists in the user directory...
Loaded plugin "TimeZoneConfiguration" .
Simple planet shader build log: "Built successfully"
Shadow planet shader build log: "Built successfully"
Using vertex shader for atmosphere rendering.
Atmosphere shader build log: "Built successfully"
Build log after adding a Mat4d transform shader: "Built successfully"
Build log after adding a stereographic projection shader: "Built successfully"

Pierluigi Panunzi (piellepi) wrote :
summary: - wrong rendering of Saturn shadow
+ wrong rendering of Planet's shadow
Changed in stellarium:
importance: Undecided → High
status: New → Confirmed
milestone: none → 0.12.1
treaves (treaves) wrote :

I do not think the shadow is too small; I think it's a matter of perception, and how the eye tries to follow lines.

Unless you can provide evidence, versus your observations, there is nothing that can be done here.

Pierluigi Panunzi (piellepi) wrote :

Hi!
I have recreated the same situation for Saturn for the exact date ( 2016 january 24th) with the well known program Celestia.
The snapshot has quite the same geometry as the picture from Stellarium, but in this case the shadow is definitely larger, even if shorter.
So for me the problem exists, and is non only a matter of perception...

The other problems connected with the wrong rendering of the shadow are those I indicated in previous posts: wrong timings of ingress and egress of satellites into and out of Jupiter shadow cone, reflecting in error of about 1 hour.
Now I think I'll do a geometric analysis of the two snapshots (Stellarium and Celestia) : I'll be happy to show you my results.

Then I'll search in internet for correct timings of Jupiter's satellites event in order to compare values shown in Stellarium.
Thanks!
Pierluigi

Pierluigi Panunzi (piellepi) wrote :

Hi again!
I used Adobe Illustrator to study the geometry involved in the shadow casting of Saturn: this is my analysis for Celestia rendering.

Clearly the shadow ellipse (drawn in red) is tangent to Saturn circonference (not drawn, but easily recognizable): the effect is a shadow that casts itself onto the rings.

I admit that there are errors in the drawing itself, but this picture gives a clear idea of the situation involved in objects casting shadows.

BTW: I am a programmer since many many years and I know problems and difficulties related to shadow rendering in OpenGL! I'm quite expert in Astronomical matters like Eclipse and Celestial Mechanics...
And, why not, If I had time, I'd like to collaborate with you all, in this project I followed since the first versions!!

Thanks for your attention

Pierluigi Panunzi (piellepi) wrote :

And now this is my analysis of Stellarium snapshot.
As you can see in my study with Adobe Illustrator, used in order to superimpose an ellipse to the picture, I found what definitely is NOT a perception problem!!

As you can see from the image the ellipse is not tangent to the circumference of Saturn, as it was CLEARLY visible directly from the original picture: the shadow is incorrectly smaller than needed.

treaves, I hope I have convinced you, showing that the shadow ellipse is completely wrong, as I stated in the first post!!

Do you need other evidences of this problem? :-)

I like Stellarium very much, I always use it for my Astronomical articles in my web site (www.astronomia.com) and I always recommend Stellarium for Astronomical scientifical purposes!
BTW just these days I'm writing (in italian, sorry!) a small guide of Stellarium, you can find in the forum...

Thanks again, friends!

Changed in stellarium:
milestone: 0.12.1 → 0.12.2
Changed in stellarium:
status: Confirmed → In Progress
assignee: nobody → Jörg Müller (nexyon)
Jörg Müller (nexyon) wrote :

Problem should be fixed in trunk, can you check please?

Changed in stellarium:
status: In Progress → Fix Committed
tags: added: opengl
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers