Satellite event times differ.

Bug #1114644 reported by Paul Gilmartin on 2013-02-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Stellarium
Medium
Alexander Wolf

Bug Description

Times of satellite events have changed from Stellarium 0.11.4 to 0.12.0.

On Mac OS X 10.6.8:

Viewing from Boulder, CO USA:

Lacrosse 4 Rocket
... TLE copied from Heavens-Above.com

1 26474U 00047B 13033.93076983 .00000626 00000-0 72354-4 0 2137
2 26474 067.9959 267.9135 0068507 271.5670 087.7623 14.90994452677142

Stellarium 0.11.4
    Eclipse at 2013/02/02 19:09:20

... agrees within a second with Heavens-Above.com

Stellarium 0.12.0
    Eclipse at 2013/02/02 19:08:12

... 68 seconds earlier.

Is this a change in the atmospheric refraction correction?
Boulder is at 1600m, but observer's location shouldn't affect
time of eclipse.

I suppose the algorithm has been updated and 0.12.0 is correct
and 0.11.4 and Heavens-Above.com are both wrong. I need to
look at a real satellite and time it with my wristwatch.

Are there Release Notes I should read?

Thanks,
gil

Paul Gilmartin (paulgboulder) wrote :
Paul Kitt (paul-kitt) wrote :

I wonder if this is related to my question #220771 regarding Delta T. On my Windows system running 0.12.0, the time that is displayed at the bottom of the screen and in the time panel reflect Delta T (which is 68.11 seconds on my system) instead of the actual system time. Check this by hovering your mouse over the time display at the bottom of the screen.

Paul

gzotti (georg-zotti) wrote :

The 68 seconds are obviously caused by the new DeltaT correction which is (apparently wrongly) applied here, and I would rather trust Heavens-Above!

The DeltaT correction is a new feature, and while now historians will be happy with ancient solar eclipses correctly simulated, it should not have been applied for satellites if their orbital elements are given in a UT frame (are they?).

But in any case, a comparison observation may be a good idea to get a grip on simulation accuracy!
G.

Changed in stellarium:
assignee: nobody → Alexander Wolf (alexwolf)
Paul Gilmartin (paulgboulder) wrote :

Indeed, it's Delta T. A couple nights ago, I set the MacBook on the
roof of my car and watched ISS pass. The appearance in Stellarium
very nicely matched the real sky, as it passed 4º n of Sirius, and as
it eclipsed. (I hadn't noticed previously) the time delayed by
Stellarium, however, lagged the system time by 68 seconds.

Complicated. Delta T is really a correction for the uncertainty
in the orientation of the earth. For nearby objects such as
artificial satellites this implies a parallax correction to the
apparent position.

For contemporary times and objects such as artificial satellites,
I'd prefer to see UTC displayed rather than Terrestrial Time.

Thanks,
gil

Alexander Wolf (alexwolf) wrote :

Which version more accurate?

Paul Gilmartin (paulgboulder) wrote :

I believe 0.11.4 and 0.12.0 are both accurate, by different
conventions. For satellite viewing, 0.11.4 is more useful to
me. I don't know which serious astronomers would prefer
for historical eclipses.

Thanks,
gil

Alexander Wolf (alexwolf) wrote :
Changed in stellarium:
milestone: none → 0.12.1
importance: Undecided → Medium
status: New → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
Paul Gilmartin (paulgboulder) wrote :

Excellent! The times extracted from Stellarium 0.12.1 match those in
heavens-above.com within a second. And I carried the laptop outside
last night and watched ISS pass Capella appearing very similar in the
sky and on the screen,

Thanks again,
gil

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments