planet display bug

Bug #1114036 reported by ofer gabzo on 2013-02-03
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Stellarium
High
Ferdinand Majerech

Bug Description

Hello.
just installed ver. 0.12.0.
Planets are shown as a mixture of colors when labels are off, and correctly when planet labels are on. See attachment.

Related branches

ofer gabzo (ofergabzo) wrote :
Alexander Wolf (alexwolf) wrote :

Please attach log.txt

Tuomas Teipainen (tuomastpnen) wrote :

I think this is the same bug i reported some time ago (#1093698). Alexander Wolf said it's related to nvidia GPU.

Alexander Wolf (alexwolf) wrote :

Tuomas, this is possible but I can't give guarantee :)

ofer gabzo (ofergabzo) wrote :

Hello again and thanks for the replies. I cannot find a log.txt file related to Stellarium. But there is one file in the windows/system32 folder if I remember correctly (I'm away from my pc at the moment). Is this the file you were reffering to, Alexander? btw sorry for the previous two messages. Hit enter too early...

Alexander Wolf (alexwolf) wrote :

You can get log within Stellarium (F1 -> Log)

ofer gabzo (ofergabzo) wrote :

log.txt attached

I have the same problem with AMD card under both Windows 7 and Ubuntu Linux.

Changed in stellarium:
status: New → Confirmed
importance: Undecided → High
milestone: none → 0.12.1
Fabrício Lara (fabricio-okra) wrote :

I'm having the same problem, after upgrading to the latest version.
One different behaviour is that mercury is shown correctly if the sun is in the field of view, and the same as the other planets otherwise. Zooming in, the planet is shown normally. The natural sattelites (except the moon) have the same problem.

Tommaso Zampieri (totommy) wrote :

Hi everyone, I have the same problem here using vista 32bit with ATI grafics... for example watching Jupiter I see it as a trapezoid till the FOV is 3.89°.... about the satellites it seems it depends because earlier this afternoon when the planet became visible as it is and they were just a little point, they then became trapezoids; in this moment they don't. I've attached a picture of venus and mars as trapezoid but mercury was fine.

Tommaso Zampieri (totommy) wrote :

And this is the log file

Alexander Wolf (alexwolf) wrote :

This bug possible has been fixed at previous revision, please download version 0.12.1dev1 and check its.

Download page: https://launchpad.net/stellarium/+download

Changed in stellarium:
status: Confirmed → In Progress
ofer gabzo (ofergabzo) wrote :

Hi everyone.
Problem still appears. Planets still appear as colorful trapezoids when planet labels are off. The trapezoid disappears once I mark a star with my mouse or when planet labels are on.
log file attached.
Keep up the good work.

Tommaso Zampieri (totommy) wrote :

Hi there,
the problem is still in there ALSO when I click on Saturn or Jupiter, for instance. Actually for like a millisecond, while i was moving "the sky" to search for Jupiter, the Moon appeard as a coloured trapezoid but was just a millisecond then was the old dear moon.
Log attached
Happy to help trying out the new versions but I'm not H24 on my laptop unfortunately.

Alexander Wolf (alexwolf) wrote :

OK, this bug related to shadows shaders - wrong calculation of limits?

tags: added: opengl
Changed in stellarium:
assignee: nobody → Ferdinand Majerech (kiithsacmp)
Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers