setArtFadeDuration doesn't work if you change the sky culture

Bug #1091626 reported by Ross on 2012-12-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Low
Alexander Wolf

Bug Description

On a Windows 7 machine, launch this test code (before starting, check that the art images are off):

ConstellationMgr.setArtFadeDuration(5);
ConstellationMgr.setFlagArt(true);
core.wait(5); // OK, the images are turned on in 5 seconds...
core.setSkyCulture("inuit");
core.wait(5);
ConstellationMgr.setArtFadeDuration(5);
ConstellationMgr.setFlagArt(true); // images are turned on quite immediately... setArtFadeDuration does no longer work
core.setSkyCulture("western");
ConstellationMgr.setFlagArt(false);
core.wait(5);
ConstellationMgr.setArtFadeDuration(5);
ConstellationMgr.setFlagArt(true); // no chance to make it work!

For now on, setArtFadeDuration does no longer work, even if you reset with the core.clear("natural") function. You have to re-run the program in order to make it work again.

Related branches

Alexander Wolf (alexwolf) wrote :

Can you write movie with problem (I cannot reproduce it on linux)?

Ross (rosario-ing) wrote :

I don't understand if "make a movie" means grabbing the video... If I understand right, see the attachment

Ross (rosario-ing) wrote :

Notice the speed of the last art images when they are turned on. The script I used is the code in my first post.

Changed in stellarium:
status: New → Confirmed
Changed in stellarium:
importance: Undecided → Low
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 6141 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/6141

Test script is:
ConstellationMgr.setArtFadeDuration(15);
ConstellationMgr.setFlagArt(true);
core.wait(12);
core.setSkyCulture("inuit");
ConstellationMgr.setArtFadeDuration(15);
ConstellationMgr.setFlagArt(true);
core.wait(12);
core.setSkyCulture("western");
ConstellationMgr.setArtFadeDuration(15);
ConstellationMgr.setFlagArt(true);

Changed in stellarium:
milestone: none → 0.12.2
assignee: nobody → Alexander Wolf (alexwolf)
status: Confirmed → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments