Core.wait() doesn't work right in scripts in 11.4

Bug #1051413 reported by qam1 on 2012-09-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Medium
Unassigned

Bug Description

core.wait(); is not working right in the new version 11.4

If you put a value under 1 second, it will round up to 1

For instance, if your line is core.wait(0.25);

the script will wait a full 1 second instead of a quarter of a second. No matter what decimal you put in, it will wait 1 second

It looks like somehow in version 11.4 core.wait() can only do integers of being able to do decimals (double).

Here's an simple example to show

// Name: 1 Hour advance to check core.wait bug
// License: Public Domain
// Author: Qam1
// Description: 1 Hour advance to check core.wait bug
//

q = 1
while (q == 1)
{
core.setDate("+1 hours");
core.wait(0.1);
}

Please make this a critical bug, most of my (and I am sure other people's) scripts I made for Stellarium (and my private ones) now don't work effectively.

Qam1

qam1 (qam1) wrote :

I am using windows 7 and the 64 bit version of Stellarium 0.11.4

On a hunch from a discussion in the forums I downloaded, installed and ran the 32 Bit version of 0.11.4 and wa-la the bug is not there.

So this bug is in the 64 bit Windows version only (I don't know about mac or Linux).

tags: added: win64
Changed in stellarium:
status: New → Confirmed
Alexander Wolf (alexwolf) wrote :
tags: added: qt
Changed in stellarium:
importance: Undecided → Medium
Alexander Wolf (alexwolf) wrote :

This issue like Qt-related issue for Windows x64, but possible this is Stellarium issue (need workaround for x64 libraries?).

henrysky (henry-leung-2010) wrote :

Stellarium 0.13.0 with Mac OSX 10.9.2 work OK...I have tested core.wait(0.1) as well as core.wait(10)

But for Windows 7x 64 with stellarium 0.12.4 x64.....this problem still exist, stellarium ignore core.wait(0.1) and even core.wait(10)

tags: added: scripting windows
Alexander Wolf (alexwolf) wrote :

Anybody can check it on modern versions of Stellarium?

Alexander Wolf (alexwolf) wrote :

I can't reproduce this bug anymore. Please check any 0.13.xx.0 version.

Changed in stellarium:
milestone: none → 0.14.0
Changed in stellarium:
status: Confirmed → In Progress
Changed in stellarium:
status: In Progress → Fix Released
milestone: 0.14.0 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers