Sky image loading with altitude/azimuth coordinates

Reported by Sibi Antony on 2012-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Wishlist
Sibi Antony

Bug Description

Not a bug. Only a feature addition.

This is to provide compatibility with the old 'image' command in stratoscript. The intention is to load an image using altitude/azimuth coordinates and have the image distorted according to the azimuthal grid. This will also be useful for dome projections, where image distorted with azimuthal reference frame is more suitable for dome view. As of now the skylayer only draws using an Equatorial reference frame.

Related branches

Sibi Antony (sibi-antony) wrote :

Patch attached. I've added a frametype property to StelSkyLayer. The new APi - loadSkyImageAltAz() is leveraged from the existing loadSkyImage() method.

Changed in stellarium:
assignee: nobody → Sibi Antony (sibi-antony)
importance: Undecided → Wishlist
milestone: none → 0.11.4
Sibi Antony (sibi-antony) wrote :

Some screenshots, on how it looks like.

I hope this also may solve the problem in here : https://sourceforge.net/projects/stellarium/forums/forum/278769/topic/5335777

Sibi Antony (sibi-antony) wrote :
Alexander Wolf (alexwolf) wrote :

Please add braces for lines since an 162 in file src/core/StelSkyLayerMgr.cpp

Sibi Antony (sibi-antony) wrote :

Okay, done.

Alexander Wolf (alexwolf) wrote :
Changed in stellarium:
status: New → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers