golang-1.16 build failure, go-srpm-macros issue

Bug #1968583 reported by Scott Little
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Fix Released
Medium
Gleb Aronsky

Bug Description

Brief Description
-----------------
golang-1.16 fails to build if golang-1.17 builds first. The issue
seems to center on go-srpm-macros, which 1.16 builds, but which 1.17
has split out into an independent package.

Severity
--------
Critcal

Steps to Reproduce
------------------
Intermittent if using:
build-pkgs --clean
build-pkgs

fully reproducible with:
build-pkgs golang-1.17.5
build-pkgs golang-1.16.12

Expected Behavior
------------------
All packages build

Actual Behavior
----------------
golang-1.16.12 fails to build on CentOS

Reproducibility
---------------
intermittent for full builds
100% for incremental builds that involve golang-1.16.12

System Configuration
--------------------
N/A

Branch/Pull Time/Commit
-----------------------
April 8 2022

Last Pass
---------
Prior yo introduction of golang-1.17.5

Timestamp/Logs
--------------
DEBUG util.py:587: Getting requirements for golang-1.16.12-1.16.12-2.tis.3.src
DEBUG util.py:587: --> Already installed : coreutils-8.22-23.el7.x86_64
DEBUG util.py:587: --> glibc-static-2.17-323.el7_9.x86_64
DEBUG util.py:587: --> golang-1.17.5-1.17.5-1.tis.2.x86_64
DEBUG util.py:587: --> Already installed : hostname-3.13-3.el7.x86_64
DEBUG util.py:587: --> Already installed : pcre-devel-8.32-17.el7.x86_64
DEBUG util.py:587: --> Already installed : 4:perl-5.16.3-299.el7_9.x86_64
DEBUG util.py:587: --> Already installed : procps-ng-3.3.10-28.el7.x86_64
DEBUG util.py:587: --> Running transaction check
DEBUG util.py:587: ---> Package glibc-static.x86_64 0:2.17-323.el7_9 will be installed
DEBUG util.py:587: ---> Package golang-1.17.5.x86_64 0:1.17.5-1.tis.2 will be installed
DEBUG util.py:587: --> Processing Dependency: go-srpm-macros = 2-17.el7 for package: golang-1.17.5-1.17.5-1.tis.2.x86_64
DEBUG util.py:587: Package golang is obsoleted by golang-1.17.5, but obsoleting package does not provide for requirements
DEBUG util.py:587: --> Processing Dependency: golang-1.17.5-bin = 1.17.5-1.tis.2 for package: golang-1.17.5-1.17.5-1.tis.2.x86_64
DEBUG util.py:587: --> Processing Dependency: golang-1.17.5-src = 1.17.5-1.tis.2 for package: golang-1.17.5-1.17.5-1.tis.2.x86_64
DEBUG util.py:587: --> Running transaction check
DEBUG util.py:587: ---> Package golang-1.17.5.x86_64 0:1.17.5-1.tis.2 will be installed
DEBUG util.py:587: --> Processing Dependency: go-srpm-macros = 2-17.el7 for package: golang-1.17.5-1.17.5-1.tis.2.x86_64
DEBUG util.py:587: Package golang is obsoleted by golang-1.17.5, but obsoleting package does not provide for requirements
DEBUG util.py:587: ---> Package golang-1.17.5-bin.x86_64 0:1.17.5-1.tis.2 will be installed
DEBUG util.py:587: ---> Package golang-1.17.5-src.noarch 0:1.17.5-1.tis.2 will be installed
DEBUG util.py:587: --> Finished Dependency Resolution
DEBUG util.py:587: Error: Package: golang-1.17.5-1.17.5-1.tis.2.x86_64 (local_build_repo)
DEBUG util.py:587: Requires: go-srpm-macros = 2-17.el7
DEBUG util.py:587: Available: go-srpm-macros-2-17.el7.noarch (StxCentos7Distro)
DEBUG util.py:587: go-srpm-macros = 2-17.el7
DEBUG util.py:587: Available: golang-1.11.2-3.el7.x86_64 (StxCentos7Distro)
DEBUG util.py:587: go-srpm-macros

Test Activity
-------------
Build

Workaround
----------
build-pkgs --clean golang-1.17.5
build-pkgs golang-1.16.12
build-pkgs

Revision history for this message
Ghada Khalil (gkhalil) wrote :

screening: stx.7.0 / medium - build issue, but there is a workaround

tags: added: stx.build
Changed in starlingx:
importance: Undecided → High
status: New → Triaged
tags: added: stx.7.0
Changed in starlingx:
importance: High → Medium
Ghada Khalil (gkhalil)
Changed in starlingx:
importance: Medium → Critical
Changed in starlingx:
assignee: nobody → Gleb Aronsky (gleb-aronsky)
Revision history for this message
Ghada Khalil (gkhalil) wrote :

Increased the priority based on info from Scott that the build failure rate is high due to this issue.

Revision history for this message
Ghada Khalil (gkhalil) wrote :

Lowering priority as this intermittent build issue has not been seen in the last two weeks.

Changed in starlingx:
importance: Critical → Medium
Revision history for this message
Scott Little (slittle1) wrote :
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to compile (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/starlingx/compile/+/842811

Changed in starlingx:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to compile (master)

Reviewed: https://review.opendev.org/c/starlingx/compile/+/842811
Committed: https://opendev.org/starlingx/compile/commit/c0294ad80e3c5a66ebc1a23547565cb38266637a
Submitter: "Zuul (22348)"
Branch: master

commit c0294ad80e3c5a66ebc1a23547565cb38266637a
Author: Gleb Aronsky <email address hidden>
Date: Wed May 11 13:02:21 2022 -0400

    Remove dependency on go_srpm_macros for go 1.17.5

    go-srpm-macros are not needed to compile go 1.17.5 and should be removed
    as a dependency

    Added obsolescences to align with go 1.16.12

    Tested: full build
    Tested: incremental go 1.17.5 build build
    Tested: built and installed iso

    Closes-Bug: 1968583
    Bug: 33885
    Change-Id: I4b8dd2b2dc4264a727a0097bcc28c7f046579115

Changed in starlingx:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers