stx-platformclients docker image build doesn't include the correct content

Bug #1891416 reported by Difu Hu
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Fix Released
High
Davlet Panech

Bug Description

Brief Description
-----------------
Remote CLI “dcmanager fw-update-strategy show” returns an error when use image docker.io/starlingx/stx-platformclients:stx.5.0-v1.4.0

Severity
--------
Major

Steps to Reproduce
------------------
precondition: configure WindShare Container-backed Remote CLI and Client
execute "dcmanager fw-update-strategy show" from client

Expected Behavior
------------------
"dcmanager fw-update-strategy show" works correctly.

Actual Behavior
----------------
"dcmanager fw-update-strategy show" command doesn't exist.

Reproducibility
---------------
yes

System Configuration
--------------------
Lab-name: DC-3

Branch/Pull Time/Commit
-----------------------
2020-08-11_20-00-00

Last Pass
---------
N/A

Timestamp/Logs
---------
$ source remote_client_platform.sh
$ dcmanager fw-update-strategy show
dcmanager: 'fw-update-strategy show' is not a dcmanager command. See 'dcmanager --help'.

Test Activity
-------------
Functional Testing

Revision history for this message
Ghada Khalil (gkhalil) wrote : Re: Remote CLI “dcmanager fw-update-strategy show” returns an error when using image stx-platformclients:stx.5.0-v1.4.0

As per Don Penney's investigation, this appears to be a docker build issue introduced some weeks ago. See email sent to stx-discuss:
http://lists.starlingx.io/pipermail/starlingx-discuss/2020-August/009415.html

summary: - Remote CLI “dcmanager fw-update-strategy show” returns an error when use
- image stx-platformclients:stx.5.0-v1.4.0
+ Remote CLI “dcmanager fw-update-strategy show” returns an error when
+ using image stx-platformclients:stx.5.0-v1.4.0
tags: added: stx.build
Changed in starlingx:
importance: Undecided → High
Revision history for this message
Ghada Khalil (gkhalil) wrote :

stx.5.0 / high priority - this needs to be addressed for that the platform-clients docker image can be updated with new content from the release. Note: This is also an issue for stx.4.0, but is less severe as it's not likely the image will need to be updated in that branch.

Changed in starlingx:
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Triaged
tags: added: stx.5.0
Changed in starlingx:
assignee: nobody → zhipeng liu (zhipengs)
Revision history for this message
zhipeng liu (zhipengs) wrote :

It needs to patching cgtsclient,fmclient and distributedcloud_client to support py3 wheel build.
As talked with Chant(Chengde), he will take this task.

Thanks!
Zhipeng

YU CHENGDE (chant)
Changed in starlingx:
assignee: zhipeng liu (zhipengs) → YU CHENGDE (chant)
Revision history for this message
Ghada Khalil (gkhalil) wrote :

Is there an update on this issue?

Revision history for this message
YU CHENGDE (chant) wrote :

Modiy the spec for distributedcloud-client, fmclient, cgts-client

https://review.opendev.org/#/c/762341/
https://review.opendev.org/#/c/762340/
https://review.opendev.org/#/c/762342/

build-rpms successfully
build-iso successfully

Next step, I will deploy a distributed cloud, and try the command is workable or not

Revision history for this message
YU CHENGDE (chant) wrote :

log form build-iso

Revision history for this message
Ghada Khalil (gkhalil) wrote :

Adding the latest discussion on this topic from the mailing list archives:
http://lists.starlingx.io/pipermail/starlingx-discuss/2020-September/009544.html

Revision history for this message
Ghada Khalil (gkhalil) wrote :

Is there an update on this?

Revision history for this message
Ghada Khalil (gkhalil) wrote :

This is an issue with building the stx-platformclients docker image. Title is updated to better reflect the issue. As discussed with Frank Miller, assigning to the build team.

Changed in starlingx:
assignee: YU CHENGDE (chant) → Davlet Panech (dpanech)
summary: - Remote CLI “dcmanager fw-update-strategy show” returns an error when
- using image stx-platformclients:stx.5.0-v1.4.0
+ stx-platformclients docker image build doesn't include the correct
+ content
Changed in starlingx:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to root (master)

Reviewed: https://review.opendev.org/c/starlingx/root/+/785508
Committed: https://opendev.org/starlingx/root/commit/2bdac9ac3b09332604919c8e7d39c1676c106ae5
Submitter: "Zuul (22348)"
Branch: master

commit 2bdac9ac3b09332604919c8e7d39c1676c106ae5
Author: Davlet Panech <email address hidden>
Date: Thu Apr 8 15:17:44 2021 -0400

    Build and use py2 wheels with py2 projects

    Current build process can't handle python2-based projects because we
    only build wheels based on Ussury (python3). This patch fixes this.

    - build-wheels/docker/stable-wheels-py2.cfg
    - build-wheels/docker/dev-wheels-py2.cfg
      Resurrected original cfg files from commit
      aa317323716a7f5bb844bb8867eeb8b01313b51e (before upgrade to Ussuri)
      and saved with -py2 suffix

    - build-wheels/docker/centos-dockerfile
      Install python2 packages in addition to python3

    - build-wheels/docker/docker-build-wheel.sh
      * Build with python3 or python2 depending on the environment
      * Suppress status message at the end because its better handled by the
        parent script (build-base-wheels.sh)

    - build-wheels/build-base-wheels.sh
      * Generate 2 wheel directories, "base" and "base-py2" at each
        invocation
      * Use the same builder image and docker script (with different
        environment) to generate wheels based on different cfg files.
        Save python3 wheels in "base" and python2 wheels in "base-py2"

    - build-wheels/build-wheel-tarball.sh
      * New command-line parameter --python2: generate *-wheels-py2.tar
        from "base-py2"
      * Use ussuri or train constraints depending on the presence of
        --python2

    - build-docker-images/build-stx-images.sh
      * Use *-wheels-py2.tar for python2/loci projects
      * Fail early on missing --wheels/--wheels-py2
      * Fail if multiple projects use the same LABEL
      * Remove support for config files

    - build-docker-images/docker-image-build-centos-dev.cfg
    - build-docker-images/docker-image-build-centos-stable.cfg
      Removed

    Change-Id: I2ca444f258a537ed2ba6f68206d32cf59e1802b4
    Partial-Bug: 1891416
    Signed-off-by: Davlet Panech <email address hidden>

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to root (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/starlingx/root/+/786486

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to clients (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/starlingx/clients/+/786490

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to root (master)

Reviewed: https://review.opendev.org/c/starlingx/root/+/786486
Committed: https://opendev.org/starlingx/root/commit/52ca64eab3d3911cae010aa690621e3df82f6abe
Submitter: "Zuul (22348)"
Branch: master

commit 52ca64eab3d3911cae010aa690621e3df82f6abe
Author: Davlet Panech <email address hidden>
Date: Thu Apr 15 15:07:56 2021 -0400

    Update stx-platformclients tag to stx.5.0-v1.4.1

    This commit updates the tag to pick up the patch that builds this image
    in python2, rather than python3 environment because stx-platformclients
    currently doesn't support python3.

    Change-Id: Ic8785d271f9ea7311708464a8cb75cc306ef209c
    Partial-Bug: 1891416
    Signed-off-by: Davlet Panech <email address hidden>

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to clients (master)

Reviewed: https://review.opendev.org/c/starlingx/clients/+/786490
Committed: https://opendev.org/starlingx/clients/commit/0c2645d8ddc59d84dde75a558f3b1660b0fc3206
Submitter: "Zuul (22348)"
Branch: master

commit 0c2645d8ddc59d84dde75a558f3b1660b0fc3206
Author: Davlet Panech <email address hidden>
Date: Thu Apr 15 15:31:27 2021 -0400

    Update stx-platformclients tag to stx.5.0-v1.4.1

    This commit updates the tag to pick up the patch that builds this image
    in python2, rather than python3 environment because stx-platformclients
    currently doesn't support python3.

    Change-Id: Ie254debfeee9c9a5cb1ec24a16b6075a0a326077
    Depends-On: https://review.opendev.org/c/starlingx/root/+/786486
    Depends-On: https://review.opendev.org/c/starlingx/clients/+/786504
    Closes-Bug: 1891416
    Signed-off-by: Davlet Panech <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released
Revision history for this message
Ghada Khalil (gkhalil) wrote :

@Davlet, please cherrypick any commits that didn't make it to the r/stx.5.0 release branch

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to root (r/stx.5.0)

Fix proposed to branch: r/stx.5.0
Review: https://review.opendev.org/c/starlingx/root/+/786886

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to clients (r/stx.5.0)

Fix proposed to branch: r/stx.5.0
Review: https://review.opendev.org/c/starlingx/clients/+/786890

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to root (r/stx.5.0)

Reviewed: https://review.opendev.org/c/starlingx/root/+/786886
Committed: https://opendev.org/starlingx/root/commit/b91c6ddf672f7eabacf46b5a63a81605fabb4d0e
Submitter: "Zuul (22348)"
Branch: r/stx.5.0

commit b91c6ddf672f7eabacf46b5a63a81605fabb4d0e
Author: Davlet Panech <email address hidden>
Date: Thu Apr 15 15:07:56 2021 -0400

    Update stx-platformclients tag to stx.5.0-v1.4.1

    This commit updates the tag to pick up the patch that builds this image
    in python2, rather than python3 environment because stx-platformclients
    currently doesn't support python3.

    Change-Id: Ic8785d271f9ea7311708464a8cb75cc306ef209c
    Partial-Bug: 1891416
    Signed-off-by: Davlet Panech <email address hidden>
    (cherry picked from commit 52ca64eab3d3911cae010aa690621e3df82f6abe)

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to clients (r/stx.5.0)

Reviewed: https://review.opendev.org/c/starlingx/clients/+/786890
Committed: https://opendev.org/starlingx/clients/commit/6f82077370dd730dc3e7bf50febd0ee7408e5ee4
Submitter: "Zuul (22348)"
Branch: r/stx.5.0

commit 6f82077370dd730dc3e7bf50febd0ee7408e5ee4
Author: Davlet Panech <email address hidden>
Date: Thu Apr 15 15:31:27 2021 -0400

    Update stx-platformclients tag to stx.5.0-v1.4.1

    This commit updates the tag to pick up the patch that builds this image
    in python2, rather than python3 environment because stx-platformclients
    currently doesn't support python3.

    Change-Id: Ie254debfeee9c9a5cb1ec24a16b6075a0a326077
    Closes-Bug: 1891416
    Depends-On: https://review.opendev.org/c/starlingx/root/+/786886
    Signed-off-by: Davlet Panech <email address hidden>
    (cherry picked from commit 0c2645d8ddc59d84dde75a558f3b1660b0fc3206)

Ghada Khalil (gkhalil)
tags: added: in-r-stx50
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to root (f/centos8)

Fix proposed to branch: f/centos8
Review: https://review.opendev.org/c/starlingx/root/+/792232

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to root (f/centos8)
Download full text (24.5 KiB)

Reviewed: https://review.opendev.org/c/starlingx/root/+/792232
Committed: https://opendev.org/starlingx/root/commit/7cb55d28111dbf7458ed3f01a5eda5c4dfdb124b
Submitter: "Zuul (22348)"
Branch: f/centos8

commit f457bd15b9ce0be512ec96abcb9b858b0bab2ea8
Author: Scott Little <email address hidden>
Date: Fri Apr 16 01:39:17 2021 -0400

    Improved branching tools

    create_branches_and_tags.sh:
    - Update the .gitreview files in branched git repos.
    - When updating a manifest, add the ability to update and
      use the default revision field.
    - Create two levels of manifest lockdown, soft and hard.
      Soft lockdown only sets sha revisions on unbranched projects
      that lack a revision, or set the revision to master.
      Hard lockdown applies to all unbranched projects.

    push_branches_tags.sh:
    - opendev no longer accepts 'git push' for the delivery of
      new branches with updates. Instead we must now
      use separate commands to deliver the tag, the branch,
      and any updates.

    Closes-Bug: 1924762
    Signed-off-by: Scott Little <email address hidden>
    Change-Id: I6d669ddc80cc9b3cb9e72d65a64589dbccf43ae3

commit 0babd33b6d851dd11492c26e92c8a6ac2c2557de
Author: Rafael Jardim <email address hidden>
Date: Wed May 12 11:25:54 2021 -0300

    Update stx-platformclients tag to stx.5.0-v1.4.3

    This commit updates the image with the updated clients.

    Test:
    Some normal commands
    Commands related with https dcmanager that wasn't working
    System application-upload that wasn't working when executed
    from remote cli

    Closes-Bug: 1928233
    Closes-Bug: 1928231
    Signed-off-by: Rafael Jardim <email address hidden>
    Change-Id: I8a0d12f699336a4412be5ff3c73cfb8d59038780

commit a163d7723e659e89c37ec933d1b0f9aa638a6a73
Author: Cole Walker <email address hidden>
Date: Wed May 5 09:39:17 2021 -0400

    Update image tag for notificationservice-base

    Update image tag to stx.5.0-v1.0.4 for notificationservice-base

    Closes-Bug: 1924201
    Closes-Bug: 1924197

    Signed-off-by: Cole Walker <email address hidden>
    Change-Id: Id863c4f154cc0b39e30ee8986fc07f9856a22826

commit 84c45f5e3a241237887af9db89d8c0aa1f8923e0
Author: Charles Short <email address hidden>
Date: Sun May 2 12:04:04 2021 -0400

    Fix wheels tarball generation

    In d7c5a54ab94bce6635b83d91a807d28f97836a81, django was dropped in favor
    of rfc3986. However the wheel was not added to the build-wheels
    generation which breaks the docker images. Also add the migrate wheel
    since it was mising as well. Add the required wheels in order to
    build the docker image properly.

    Test:
    - Build new centos-stable-wheels tarball
    - Build stx-keystone-api-proxy container

    Closes-Bug: 1926795

    Signed-off-by: Charles Short <email address hidden>
    Change-Id: Ib6f0abfdcc82ca14f92ebc5b45fe8df961e804ee

commit 062353b6de7d4b0e017203c3e6086891bd6b9213
Author: Cole Walker <email address hidden>
Date: Mon May 3 09:48:54 2021 -0400

    Update image tag for notificationclient-base...

tags: added: in-f-centos8
Ghada Khalil (gkhalil)
tags: removed: stx.retestneeded
Revision history for this message
Thiago Paiva Brito (outbrito) wrote (last edit ):

Hi folks,

I got into this LP after I failed to build the stx-platformclients and stx-pci-irq-affinity-agent following the docs and was checking the change at [1].

Shouldn't we have changed the docs to reflect the changes done here? I don't see any reference to use --python2 on build-wheels-tarball.sh or to set --wheels-py2 on build-stx-images.sh on the main docker image build doc referece at [2]:

[1] https://opendev.org/starlingx/root/commit/2bdac9ac3b09332604919c8e7d39c1676c106ae5
[2] https://docs.starlingx.io/developer_resources/build_docker_image.html#building-wheels

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers