New version of flake8 breaks zuul for sysinv

Bug #1878276 reported by Al Bailey on 2020-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Al Bailey

Bug Description

Brief Description
-----------------
On May 11, 2020 a new flake8 and pycodestyle were released on pypi.

Those components are typically pulled in by 'hacking' in the test-requirements.
Reviews that normally pass, are now failing as different checks are now performed.

Severity
--------
Major. Blocks any code submissions from being able to merge in stx/config

Steps to Reproduce
------------------
cd stx/config/sysinv/sysinv/sysinv
tox -e flake8 --recreate

Expected Behavior
------------------
Tox and Zuul should pass.

Actual Behavior
----------------
Zuul pep8 reports new errors that it did not previously report.

Reproducibility
---------------
Dev Env. Happens with a 'fresh' tox env such as what zuul uses.

System Configuration
--------------------
N/A

Branch/Pull Time/Commit
-----------------------
After May 11

Last Pass
---------
Yes. Any zuul reviews prior to May 11.

Timestamp/Logs
--------------
./sysinv/conductor/manager.py:4972:46: E741 ambiguous variable name 'l'
./sysinv/puppet/kubernetes.py:380:13: E741 ambiguous variable name 'l'
./sysinv/common/ceph.py:251:13: E741 ambiguous variable name 'l'
./sysinv/openstack/common/setup.py:39:17: E741 ambiguous variable name 'l'
./sysinv/api/controllers/v1/host.py:2423:13: E741 ambiguous variable name 'l'
./sysinv/api/controllers/v1/profile.py:792:17: E741 ambiguous variable name 'l'

Test Activity
-------------
cd sysinv
tox -e flake8 --recreate

 Workaround
 ----------
 There isn't one. Either a code change is required, which introduces risk to currently working code. Or setting the upper version is required which allows the code to act as it already was.
Other openstack projects (including 'hacking') are setting the upper limit
https://github.com/openstack/hacking/commit/d30425b3d89ed47c9e19f17062d74ed395353a4d

Al Bailey (albailey1974) on 2020-05-12
Changed in starlingx:
assignee: nobody → Al Bailey (albailey1974)

Fix proposed to branch: master
Review: https://review.opendev.org/727396

Changed in starlingx:
status: New → In Progress
Al Bailey (albailey1974) wrote :

Looks like cgtsclient fails in the same repo.
tscofig and controllerconfig are fine.

Reviewed: https://review.opendev.org/727396
Committed: https://git.openstack.org/cgit/starlingx/config/commit/?id=bc9cde71a0bbcd099427b8808e0bdb1b78cb9725
Submitter: Zuul
Branch: master

commit bc9cde71a0bbcd099427b8808e0bdb1b78cb9725
Author: albailey <email address hidden>
Date: Tue May 12 14:24:17 2020 -0500

    Specify an upper limit for flake8 and pycodestyle

    Both flake8 and pycodestyle were updated on May 11
    which caused zuul jobs to start failing.

    The copyrights were updated as a way of triggering
    zuul to run the flake8 jobs associated with the
    test-requirements.txt

    Similar solution as:
    https://review.opendev.org/#/c/727133/

    Change-Id: Ia2b97203e7ab767586ee7393ac08fcf781af7609
    Closes-Bug: 1878276
    Signed-off-by: albailey <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released
Ghada Khalil (gkhalil) wrote :

stx.4.0 / critical priority as this blocks code submissions

Changed in starlingx:
importance: Undecided → Critical
tags: added: stx.4.0 stx.zuul
Download full text (37.5 KiB)

Reviewed: https://review.opendev.org/729812
Committed: https://git.openstack.org/cgit/starlingx/config/commit/?id=539d476456277c22d0dcbc3cbbc832e623242264
Submitter: Zuul
Branch: f/centos8

commit 320cc40de8518787c2be234d7fdf88ec0a462df2
Author: Don Penney <email address hidden>
Date: Wed May 13 13:06:11 2020 -0400

    Add auto-versioning to starlingx/config packages

    This update makes use of the PKG_GITREVCOUNT variable to auto-version
    the packages in this repo.

    Change-Id: I3a2c8caeb4b4647608978b1f2ccfcf0661508803
    Depends-On: https://review.opendev.org/727837
    Story: 2006166
    Task: 39766
    Signed-off-by: Don Penney <email address hidden>

commit d9f2aea0fb228ed69eb9c9262e29041eedabc15d
Author: Sharath Kumar K <email address hidden>
Date: Wed Apr 22 16:22:22 2020 +0200

    De-branding in starlingx/config: CGCS -> StarlingX

    1. Rename CGCS to StarlingX for .spec files

    Test:
    After the de-brand change, bootimage.iso has been built in the flock
    Layer and installed on the dev machine to validate the changes.

    Please note, doing de-brand changes in batches, this is batch9 changes.

    Story: 2006387
    Task: 39524

    Change-Id: Ia1fe0f2baafb78c974551100f16e6a7d99882f15
    Signed-off-by: Sharath Kumar K <email address hidden>

    De-branding in starlingx/config: CGCS -> StarlingX

    1. Rename CGCS to StarlingX for .spec file
    2. Rename TIS to StarlingX for .service files

    Test:
    After the de-brand change, bootimage.iso has been built in the flock
    Layer and installed on the dev machine to validate the changes.

    Please note, doing de-brand changes in batches, this is batch10 changes.

    Story: 2006387
    Task: 36202

    Change-Id: I404ce0da2621495175ad31489e9ad6f7b0211e26
    Signed-off-by: Sharath Kumar K <email address hidden>

commit d141e954fa6bbf688929ec90d1b6604a97792c43
Author: Teresa Ho <email address hidden>
Date: Tue Mar 31 10:08:57 2020 -0400

    Sysinv extensions for FPGA support

    This update adds cli and restapi to support FPGA device
    programming.

    CLI commands:
    system device-image-apply
    system device-image-create
    system device-image-delete
    system device-image-list
    system device-image-remove
    system device-image-show
    system device-image-state-list
    system device-label-list
    system host-device-image-update
    system host-device-image-update-abort
    system host-device-label-assign
    system host-device-label-list
    system host-device-label-remove

    Story: 2006740
    Task: 39498

    Change-Id: I556c2e7a51b3931b5a66ab27b67f51e3a8aebd9f
    Signed-off-by: Teresa Ho <email address hidden>

commit 491cca42ed854d2cb3ee3646b93c56a4f45f563c
Author: Elena Taivan <email address hidden>
Date: Wed Apr 29 11:25:26 2020 +0000

    Qcow2 conversion to raw can be done using 'image-conversion' filesystem

    1. Conversion filesystem can be added before/after
       stx-openstack is applied
    2. If conversion filesystem is added after stx-openstack
       is applied, changes to stx-openstack will only take effec...

tags: added: in-f-centos8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers