nfv git updates fail Zuul due to bashate version dependency

Bug #1869251 reported by Eric MacDonald on 2020-03-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
High
Eric MacDonald

Bug Description

nfv test-requirements.txt accepts latest version greater than .2 (bashate >= 0.2)

bashate 2.0.0 was released Mar 3rd and is py3 only.

Our system is not py3 ready.

Severity
--------
Minor - git delivery issue only. no customer service impact.

Steps to Reproduce
------------------
Deliver a nfv git update

Expected Behavior
------------------
Zuul should pass

Actual Behavior
----------------
Zuul fails ; nfv-tox-py27 FAILURE

Reproducibility
---------------
100% reproducible

System Configuration
--------------------
N/A

Branch/Pull Time/Commit
-----------------------
~March 3, 2020

Last Pass
---------
Feb 6 with https://github.com/starlingx/nfv/commit/ab4518cba4a5f412b3cc98af5f6efcc9aee21d98

Timestamp/Logs
--------------
ERROR: Package 'bashate' requires a different Python: 2.7.17 not in '>=3.5'

Test Activity
-------------
Code Development

Workaround
----------
None

Changed in starlingx:
assignee: nobody → Eric MacDonald (rocksolidmtce)
description: updated
Ghada Khalil (gkhalil) wrote :

stx.4.0 / high priority - this will prevent code merges in the nfv repo

tags: added: stx.n stx.zuul
tags: added: stx.4.0 stx.nfv
removed: stx.n
Changed in starlingx:
importance: Undecided → High
status: New → Triaged

Fix proposed to branch: master
Review: https://review.opendev.org/715694

Changed in starlingx:
status: Triaged → In Progress

Reviewed: https://review.opendev.org/715694
Committed: https://git.openstack.org/cgit/starlingx/nfv/commit/?id=af4f6aa83ef51841d7ca996d1644b514b1ede805
Submitter: Zuul
Branch: master

commit af4f6aa83ef51841d7ca996d1644b514b1ede805
Author: Eric MacDonald <email address hidden>
Date: Sun Mar 29 10:00:42 2020 -0400

    Change nfv tox requirements for bashate version

    Zuul is failing.
     Package 'bashate' requires a different Python: 2.7.17 not in '>=3.5'

    nfv test-requirements.txt accepts any version of bashate greater
    than 0.2 version. So the recent release of bashate 2.0.0 qualifies.
    However, this new version only supports py3 which is not yet fully
    supported by starlingx.

    Ths update reduces the bashate version dependency to less than 1.0.0
    so that the older 0.6 version that supports python 2.7 is used.

    Change-Id: I415f011abb4931c30c5991c2f6fda7651ddd402a
    Closes-Bug: 1869251
    Signed-off-by: Eric MacDonald <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released

Fix proposed to branch: f/centos8
Review: https://review.opendev.org/718084

Change abandoned by Lin Shuicheng (<email address hidden>) on branch: f/centos8
Review: https://review.opendev.org/716150

Reviewed: https://review.opendev.org/718084
Committed: https://git.openstack.org/cgit/starlingx/nfv/commit/?id=7ef48ee075b2a56a1f99691c45f70a5ad454fe2f
Submitter: Zuul
Branch: f/centos8

commit af4f6aa83ef51841d7ca996d1644b514b1ede805
Author: Eric MacDonald <email address hidden>
Date: Sun Mar 29 10:00:42 2020 -0400

    Change nfv tox requirements for bashate version

    Zuul is failing.
     Package 'bashate' requires a different Python: 2.7.17 not in '>=3.5'

    nfv test-requirements.txt accepts any version of bashate greater
    than 0.2 version. So the recent release of bashate 2.0.0 qualifies.
    However, this new version only supports py3 which is not yet fully
    supported by starlingx.

    Ths update reduces the bashate version dependency to less than 1.0.0
    so that the older 0.6 version that supports python 2.7 is used.

    Change-Id: I415f011abb4931c30c5991c2f6fda7651ddd402a
    Closes-Bug: 1869251
    Signed-off-by: Eric MacDonald <email address hidden>

commit ab4518cba4a5f412b3cc98af5f6efcc9aee21d98
Author: Bin Qian <email address hidden>
Date: Thu Feb 6 12:45:41 2020 -0500

    Adding job to upload commits to GitHub

    Add job to publish nfv repo to GitHub

    Change-Id: I48531be63349ab9a3b9a3cff2cdc8a6b522b457e
    Story: 2007252
    Task: 38689
    Signed-off-by: Bin Qian <email address hidden>

commit 5c13295994f03bad3e0b25c4d87690552228ac8c
Author: Kristal Dale <email address hidden>
Date: Wed Jan 15 15:39:25 2020 -0800

    Update landing pages for docs, api-ref, and release notes:

    - Use updated project name in titles/text
    - Correct text for link to Storyboard (docs)
    - Correct capitalization in section headings
    - Correct formatting for section headings
    - Update project name in link to release notes, api-ref
    - Update project name in config for docs/releasenotes/api-ref

    Story:2007193
    Task:38346

    Change-Id: I15af375869bb03120fed052ecc5ce070a5581125
    Signed-off-by: Kristal Dale <email address hidden>

tags: added: in-f-centos8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers