stx-gui zuul jobs failing pylint

Bug #1861932 reported by Al Bailey on 2020-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Al Bailey

Bug Description

Brief Description
-----------------
Zuul jobs for stx/gui are all failing pylint, despite no code changes being made.

This means that no commits can merge into stx/gui until this is fixed

Severity
--------
Critical

Steps to Reproduce
------------------
Submit a code review for stx/gui and watch it fail zuul

Expected Behavior
------------------
Submit a code review for stx/gui and hope it doesnt fail zuul, but when it does, its your own fault

Actual Behavior
----------------
Zuul failing for stx-gui due to a mismatch of un-supported python components pulled in by tox.ini

Reproducibility
---------------
Always (as of 02/04/2020)

System Configuration
--------------------
N/A

Branch/Pull Time/Commit
-----------------------
N/A Affects master and centos8 branches. Perhaps others.

Last Pass
---------
Jan 30 reviews were able to merge.

Timestamp/Logs
--------------
ERROR: could not install deps

Test Activity
-------------
Code Submission

 Workaround
 ----------
None. But I know the fix.

Al Bailey (albailey1974) on 2020-02-04
Changed in starlingx:
assignee: nobody → Al Bailey (albailey1974)

Fix proposed to branch: master
Review: https://review.opendev.org/705860

Changed in starlingx:
status: New → In Progress
Ghada Khalil (gkhalil) on 2020-02-04
tags: added: stx.zuul

Reviewed: https://review.opendev.org/705860
Committed: https://git.openstack.org/cgit/starlingx/gui/commit/?id=cf702a8390b2d28b5d17212bf5d3be26ea997ee9
Submitter: Zuul
Branch: master

commit cf702a8390b2d28b5d17212bf5d3be26ea997ee9
Author: albailey <email address hidden>
Date: Tue Feb 4 16:24:05 2020 -0600

    Fix pylint zuul failure

    The starlingx-staging repo was incorrectly being pointed at for tox
    pylint dependencies. The dependencies were colliding with
    dependencies from other repos.

    That repo is not used anymore, instead the latest stable stein is used.

    This change points at the most recently released stable/stein horizon
    (15.0.2) in the requirements.

    This change has no effect on build or deployment, only tox.

    The upper constraints zuul job overrides the stein upper constraints,
    and therefore the oslo concurrency 4.0.0 released Feb 3rd is no
    longer triggering a failed tox job.

    Closes-Bug: 1861932
    Change-Id: I3c3fd22993faf47c7e3c32bae18a7f2ab1dd031c
    Signed-off-by: albailey <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/705847
Committed: https://git.openstack.org/cgit/starlingx/gui/commit/?id=209ddafc4906b041f24438f3e2b23de5ef3e0c19
Submitter: Zuul
Branch: f/centos8

commit cf702a8390b2d28b5d17212bf5d3be26ea997ee9
Author: albailey <email address hidden>
Date: Tue Feb 4 16:24:05 2020 -0600

    Fix pylint zuul failure

    The starlingx-staging repo was incorrectly being pointed at for tox
    pylint dependencies. The dependencies were colliding with
    dependencies from other repos.

    That repo is not used anymore, instead the latest stable stein is used.

    This change points at the most recently released stable/stein horizon
    (15.0.2) in the requirements.

    This change has no effect on build or deployment, only tox.

    The upper constraints zuul job overrides the stein upper constraints,
    and therefore the oslo concurrency 4.0.0 released Feb 3rd is no
    longer triggering a failed tox job.

    Closes-Bug: 1861932
    Change-Id: I3c3fd22993faf47c7e3c32bae18a7f2ab1dd031c
    Signed-off-by: albailey <email address hidden>

commit 517ecae4810ed8b56e647f7faee6cba58317ca87
Author: Kristine Bujold <email address hidden>
Date: Mon Feb 3 16:25:32 2020 -0500

    Remove System Information panel

    This submit removes the System Information panel from Admin/System

    Story: 2007255
    Task: 38615
    Change-Id: I7df2c10700a0c967c180116d70630581eccba93e
    Signed-off-by: Kristine Bujold <email address hidden>

commit 0096f44bd25695bc6f1608bf2041b028dcc170ff
Author: Kristal Dale <email address hidden>
Date: Wed Jan 22 11:06:55 2020 -0800

    Update project name in configs/link

    - Update project name in link to release notes
    - Update project name in config for docs/releasenotes

    Story:2007193
    Task:38345

    Change-Id: Id18ed48a2e8c8b9d1828ef7b43d565a7e78869c1
    Signed-off-by: Kristal Dale <email address hidden>

commit 3fc4768f3e06214aa55bfc66345d9446941a864a
Author: Kristal Dale <email address hidden>
Date: Wed Jan 15 15:29:23 2020 -0800

    Update landing pages for docs and release notes:

    - Use updated project name in titles/text
    - Correct text for link to Storyboard (docs)
    - Correct capitalization in section headings
    - Correct formatting for section headings

    Change-Id: I0e335b082c731fbed1f6fd2ea32f082471571be1
    Signed-off-by: Kristal Dale <email address hidden>

commit 684f02d8874bb76fbd3dfc0805a6ce71b7b76050
Author: chenyan <email address hidden>
Date: Tue Oct 8 10:49:16 2019 +0800

    update stx local_settings for horizon train upgrade.

    One more field 'ignore_urls' is added into OPERATION_LOG_OPTIONS.
    This change is based on openstack stable/train.

    Story: 2006544
    Task: 36620

    Change-Id: Iafc6aecde7b4aa1378aa021a4962d058a58e8b7e
    Signed-off-by: chenyan <email address hidden>

tags: added: in-f-centos8
Ghada Khalil (gkhalil) wrote :

stx.4.0 / critical priority since this will prevent code from merging in the affected repo

Changed in starlingx:
importance: Undecided → Critical
tags: added: stx.4.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers