CENGN build failure due to updated more-itertools module

Bug #1859642 reported by Don Penney on 2020-01-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Don Penney

Bug Description

Brief Description
-----------------
A recent update to the more-itertools python module causes a failure in the CENGN build in the STX_BUILD_container_setup job:

00:00:52.319 Downloading https://files.pythonhosted.org/packages/df/8c/c278395367a46c00d28036143fdc6583db8f98622b83875403f16473509b/more-itertools-8.1.0.tar.gz (78kB)
00:00:52.485 Complete output from command python setup.py egg_info:
00:00:52.485 Traceback (most recent call last):
00:00:52.485 File "<string>", line 1, in <module>
00:00:52.485 File "/tmp/pip-build-ixeFen/more-itertools/setup.py", line 5, in <module>
00:00:52.485 from more_itertools import __version__
00:00:52.485 File "more_itertools/__init__.py", line 1, in <module>
00:00:52.485 from .more import * # noqa
00:00:52.485 File "more_itertools/more.py", line 480
00:00:52.485 yield from iterable
00:00:52.485 ^
00:00:52.485 SyntaxError: invalid syntax
00:00:52.485
00:00:52.485 ----------------------------------------
00:00:52.517 [91mCommand "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-ixeFen/more-itertools/

Severity
--------
Critical

Reproducibility
---------------
Reproducible

Branch/Pull Time/Commit
-----------------------
First build failure seen with Jan 11, 2020, master build

Reviewed: https://review.opendev.org/702471
Committed: https://git.openstack.org/cgit/starlingx/tools/commit/?id=12c3dc47720bc8d011a746faf42b824caac8faa6
Submitter: Zuul
Branch: master

commit 12c3dc47720bc8d011a746faf42b824caac8faa6
Author: Don Penney <email address hidden>
Date: Tue Jan 14 11:20:50 2020 -0500

    Constrain more-itertools for build failure

    A recent update to the more-itertools python module causes a failure
    in the STX_BUILD_container_setup CENGN build job. This module dropped
    python-2.7 support after its 5.0.0 release. The newest update causes a
    failure due to code that does not work with 2.7.

    This commit adds a builder-constraints.txt file that the Dockerfile
    passes to the pip install command to constrain module versions during
    setup of the build container, allowing us to constrain the
    more-itertools version to 5.0.0, the last version to officially
    support python 2.7.

    Change-Id: I3432c204ecd7c4ddedd8a7dea14216d4ec31e0aa
    Closes-Bug: 1859642
    Signed-off-by: Don Penney <email address hidden>

Changed in starlingx:
status: New → Fix Released
Ghada Khalil (gkhalil) wrote :

Marking for stx.2.0 & stx.3.0 given this will cause builds to fail / Critical priority.

@Don, Please cherry-pick to the release branches at your earliest convenience.

Changed in starlingx:
importance: Undecided → Critical
assignee: nobody → Don Penney (dpenney)
tags: added: stx.2.0 stx.3.0 stx.4.0 stx.build

Reviewed: https://review.opendev.org/702947
Committed: https://git.openstack.org/cgit/starlingx/tools/commit/?id=7b095f365e33a6d68d524501cd953eb04df312b1
Submitter: Zuul
Branch: r/stx.3.0

commit 7b095f365e33a6d68d524501cd953eb04df312b1
Author: Don Penney <email address hidden>
Date: Tue Jan 14 11:20:50 2020 -0500

    Constrain more-itertools for build failure

    A recent update to the more-itertools python module causes a failure
    in the STX_BUILD_container_setup CENGN build job. This module dropped
    python-2.7 support after its 5.0.0 release. The newest update causes a
    failure due to code that does not work with 2.7.

    This commit adds a builder-constraints.txt file that the Dockerfile
    passes to the pip install command to constrain module versions during
    setup of the build container, allowing us to constrain the
    more-itertools version to 5.0.0, the last version to officially
    support python 2.7.

    Change-Id: I3432c204ecd7c4ddedd8a7dea14216d4ec31e0aa
    Closes-Bug: 1859642
    Signed-off-by: Don Penney <email address hidden>
    (cherry picked from commit 12c3dc47720bc8d011a746faf42b824caac8faa6)

Reviewed: https://review.opendev.org/702948
Committed: https://git.openstack.org/cgit/starlingx/tools/commit/?id=997443e7548b7a30a632f66b3597979a0a4c5da8
Submitter: Zuul
Branch: r/stx.2.0

commit 997443e7548b7a30a632f66b3597979a0a4c5da8
Author: Don Penney <email address hidden>
Date: Tue Jan 14 11:20:50 2020 -0500

    Constrain more-itertools for build failure

    A recent update to the more-itertools python module causes a failure
    in the STX_BUILD_container_setup CENGN build job. This module dropped
    python-2.7 support after its 5.0.0 release. The newest update causes a
    failure due to code that does not work with 2.7.

    This commit adds a builder-constraints.txt file that the Dockerfile
    passes to the pip install command to constrain module versions during
    setup of the build container, allowing us to constrain the
    more-itertools version to 5.0.0, the last version to officially
    support python 2.7.

    Change-Id: I3432c204ecd7c4ddedd8a7dea14216d4ec31e0aa
    Closes-Bug: 1859642
    Signed-off-by: Don Penney <email address hidden>
    (cherry picked from commit 12c3dc47720bc8d011a746faf42b824caac8faa6)

Ghada Khalil (gkhalil) on 2020-01-21
tags: added: in-r-stx20 in-r-stx30
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers