Error in distributed cloud installation document

Bug #1858481 reported by Bart Wensley on 2020-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
High
Kristal Dale

Bug Description

Brief Description
-----------------
The DC doc (https://docs.starlingx.io/deploy_install_guides/r3_release/distributed_cloud/index.html) is wrong for AIO-SX subclouds. It says to follow the AIO-SX instructions for the subcloud - that results in the management network being configured on the loopback interface, which will not allow the subcloud to function.

There are two additional issues with this document that should also be clarified:
1. The subcloud will not go online until the route is added on the subcloud. That should be stated.
2. It should also be made clear that the “system host-route-add” command is to be run on the subcloud.

Severity
--------
Critical: unable to configure AIO-SX subcloud following the existing instructions.

Steps to Reproduce
------------------
Attempt to install an AIO-SX subcloud following the existing documentation.

Expected Behavior
------------------
Subcloud installs successfully.

Actual Behavior
----------------
The subcloud will not go online.

Reproducibility
---------------
Reproducible

System Configuration
--------------------
Distributed cloud with AIO-SX subcloud.

Branch/Pull Time/Commit
-----------------------
stx.3.0 release

Last Pass
---------
Never

Timestamp/Logs
--------------
N/A

Test Activity
-------------
Developer Testing

Workaround
----------
Follow the AIO-DX instructions (just for controller-0) to complete the installation of the AIO-SX subcloud.

Ghada Khalil (gkhalil) wrote :

stx.3.0 / high priority since the current instructions will result in the subclouds not coming online.
This should also be fixed in the stx.4.0 docs if they've been created.

tags: added: stx.3.0 stx.4.0 stx.docs
Changed in starlingx:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Kristal Dale (kdale)
Kristal Dale (kdale) on 2020-01-07
Changed in starlingx:
status: Triaged → In Progress

Reviewed: https://review.opendev.org/701474
Committed: https://git.openstack.org/cgit/starlingx/docs/commit/?id=3bf2b2de5e9c5269fd02dafe369ea3aaddc95909
Submitter: Zuul
Branch: master

commit 3bf2b2de5e9c5269fd02dafe369ea3aaddc95909
Author: Kristal Dale <email address hidden>
Date: Tue Jan 7 15:12:21 2020 -0800

    Fix instructions for dist-cloud install

    Fix the install instructions for distributed cloud:
    - Add needed detail/clarification to subcloud section
    - Clarify AIO-Simplex install on subcloud (WIP)

    Patch set 2: Wording correction per feedback.
    Patch set 3: Wording corrections and add in clarification for
    AIO-Simplex config for dist cloud

    Closes-Bug:1858481

    Change-Id: I939d1f938ea912a05bc72be83ab161f3f2040c78
    Signed-off-by: Kristal Dale <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers