Patch API has a method returning a no-result method call

Bug #1855180 reported by Al Bailey on 2019-12-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Low
Don Penney

Bug Description

Brief Description
-----------------
Pylint for cgcs-patch currently has an error code suppressed:
E1111:(assignment-from-no-return)

This code should be un-supressed and the area that is raising this error should be fixed, as it means that the code is always returning a blank result.

cgcs_patch/api/controllers/root.py:272:12: E1111: Assigning result of a function call, where the function has no return (assignment-from-no-return)

that method is calling a routine that does not return a result: https://opendev.org/starlingx/update/src/branch/master/cgcs-patch/cgcs-patch/cgcs_patch/patch_controller.py#L2266

Severity
--------
Minor

Steps to Reproduce
------------------
1) Remove E1111 from pylint.rc in cgcs_patch and run 'tox -e pylint'

The following steps are optional:
2) - open google chrome.
3) - do a search for amusing cat videos
4) - watch amusing cat videos
5) - then run step 1

Expected Behavior
------------------
pylint should run clean once that error code is fixed.

Actual Behavior
----------------
Currently will fail (because the code needs to be fixed)

Reproducibility
---------------
Its a code issue tied to a static linting tool. It can be reproduced 100% of the time.

System Configuration
--------------------
N/A

Branch/Pull Time/Commit
-----------------------
Any time after Dec 4th in master branch of starlingx/update
Error is detectable with the newer version of pylint which is introduced by
https://review.opendev.org/#/c/696949/

Last Pass
---------
N/A

Timestamp/Logs
--------------
N/A

Test Activity
-------------
Developer Development.

Don Penney (dpenney) on 2019-12-04
Changed in starlingx:
assignee: nobody → Don Penney (dpenney)

Fix proposed to branch: master
Review: https://review.opendev.org/697408

Changed in starlingx:
status: New → In Progress
Ghada Khalil (gkhalil) wrote :

Not gating any particular release as this is related to tox. Fix in master only.

tags: added: stx.update
tags: added: stx.zuul

Reviewed: https://review.opendev.org/697408
Committed: https://git.openstack.org/cgit/starlingx/update/commit/?id=678e786c5bb7fca7ac56d3cb280477252ab5a073
Submitter: Zuul
Branch: master

commit 678e786c5bb7fca7ac56d3cb280477252ab5a073
Author: Don Penney <email address hidden>
Date: Wed Dec 4 22:26:52 2019 -0500

    Address python3 pylint errors and warnings

    This commit addresses issues detected by the updated python3 pylint:
    - Added a return code to the report_app_dependencies function to
    satisfy the E1111 error reported.
    - Added line-specific pylint disable for unused-argument for cases
    where the inclusion of such arguments in the function signature was
    intentional.
    - Added line-specific pylint disable for the duplicate-except case
    found, as python3 has merged IOError into OSError, while these are
    separate exceptions in python2. Once we're running solely on python3,
    this duplicate exception handling can be dropped.

    Change-Id: I96a521288e71948f06ad0c88a12c8f475ed8bc99
    Closes-Bug: 1855180
    Signed-off-by: Don Penney <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released
Ghada Khalil (gkhalil) on 2019-12-11
Changed in starlingx:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers