cgcs-patch tox failing due to missing dependencies

Bug #1848786 reported by Al Bailey on 2019-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Low
Al Bailey

Bug Description

Brief Description
------------------
This is the same issue as was fixed for https://bugs.launchpad.net/starlingx/+bug/1846244
However it is due to a newer sysinv commit
https://review.opendev.org/#/c/686061/2/sysinv/sysinv/sysinv/sysinv/common/utils.py

This file is imported in cgcs-patch and caused a tox failure because it could not be found.

Severity
--------
Minor

Steps to Reproduce
------------------
Run tox

Expected Behavior
------------------
Tox should pass

Actual Behavior
----------------
Tox fails

Reproducibility
---------------
Reproducible

System Configuration
--------------------
Developer repo

Branch/Pull Time/Commit
-----------------------
starlingx/master

Test Activity
-------------
Coding

Al Bailey (albailey1974) wrote :

Checking with Don if we can eliminate the import of sysinv.common.utils, and therefore be more shielded from these types of errors.

Changed in starlingx:
assignee: nobody → Al Bailey (albailey1974)
Ghada Khalil (gkhalil) wrote :

Low priority - tox failure, but doesn't seem to gate code submissions thru zuul

tags: added: stx.update stx.zuul
Changed in starlingx:
importance: Undecided → Low
status: New → Triaged
Al Bailey (albailey1974) wrote :

Replacing the sysinv imports with oslo imports would require additional code changes, and should probably be done as a general cleanup activity.

The real issue is that there are entries added to test-requirements that should instead be in requirements.txt in sysinv.

That way when other repos (like update) include sysinv as a tox dependency, they will install the components that are needed to run sysinv.

I will look into cleaning up stx/config

Fix proposed to branch: master
Review: https://review.opendev.org/690131

Changed in starlingx:
status: Triaged → In Progress

Reviewed: https://review.opendev.org/690131
Committed: https://git.openstack.org/cgit/starlingx/config/commit/?id=b2881d90df736d7423bbecb237b1702891678bff
Submitter: Zuul
Branch: master

commit b2881d90df736d7423bbecb237b1702891678bff
Author: Al Bailey <email address hidden>
Date: Tue Oct 22 11:39:22 2019 -0500

    Fix tox in other repos that import sysinv

    sysinv.common.utils is imported in cgcs-patch.

    When keyring was added to that file, the tox and
    zuul jobs in cgcs-patch failed.

    The root reason for this is that when those other repos
    add sysinv as a dependency, only the requirements.txt is
    used when constructing the egg for import by tox.

    By properly relocating runtime required files from
    test-requirements.txt to requirements.txt, those other
    repos are able to import the additional required components.

    This does not impact rpms since those are driven by the
    Requires directives in the spec files.

    Change-Id: I8d9d84345a0810e311d2a50cdcbdb49056f80c2c
    Fixes-Bug: 1848786
    Signed-off-by: Al Bailey <email address hidden>

Changed in starlingx:
status: In Progress → Fix Released

Change abandoned by Al Bailey (<email address hidden>) on branch: master
Review: https://review.opendev.org/690116
Reason: no longer need this review since the bug is now fixed.

Reviewed: https://review.opendev.org/692132
Committed: https://git.openstack.org/cgit/starlingx/gui/commit/?id=7eb463e4ba891050e881a69cb648962b0c0c400e
Submitter: Zuul
Branch: master

commit 7eb463e4ba891050e881a69cb648962b0c0c400e
Author: Al Bailey <email address hidden>
Date: Wed Oct 30 07:55:17 2019 -0500

    Fix failing tox for stx-gui due to keyring imports from sysinv

    keyring is required by sysinv, however the upper-constraints were
    not being used in stx-gui, so it was pulling in a version of
    keyring that is incompatible with the STX env.

    This aligns the stx-gui upper constraints to be the same as the
    other platform components.

    Change-Id: I2d4a2f7a61c65e2753d376865e9112aa93948a35
    Related-Bug: 1848786
    Signed-off-by: Al Bailey <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers