Zuul devstack jobs failing

Bug #1848557 reported by Al Bailey on 2019-10-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Al Bailey

Bug Description

Brief Description
-----------------
StarlingX devstack jobs are unable to run due to a devstack change that looks to have dropped support for postgres:
https://opendev.org/openstack/devstack/commit/cf1c8471910924d154158f78027e46b3e0d3d840

StarlingX/config sysinv runs using postgres, so there is currently no way for devstack jobs to run, and therefore no way for commits to merge in any starlingX repo that invokes devstack as a zuul job.

We need to eliminate the devstack job from running as part of a zuul check/gate.

This is currently blocking all commits in fault and metal.

Severity
--------
Critical: Nothing can merge at the moment.

Steps to Reproduce
------------------
Submit a review to fault or metal, and watch it fail zuul.

Expected Behavior
------------------
not fail zuul devstack job.

Actual Behavior
----------------
fail zuul devstack job.

Reproducibility
---------------
Any new reviews in metal and fault. Not sure about other repos yet.

System Configuration
--------------------
N/A

Branch/Pull Time/Commit
-----------------------
Oct 17 2019

Last Pass
---------
Oct 16, 2019

Timestamp/Logs
--------------
/opt/stack/devstack/lib/database: line 111: recreate_database_: command not found

Test Activity
-------------
Other - Gerrit.

Al Bailey (albailey1974) on 2019-10-17
Changed in starlingx:
assignee: nobody → Al Bailey (albailey1974)

Fix proposed to branch: master
Review: https://review.opendev.org/689232

Changed in starlingx:
status: New → In Progress

Reviewed: https://review.opendev.org/689234
Committed: https://git.openstack.org/cgit/starlingx/metal/commit/?id=c0e97fcb36d6d12e3c67b100ac189a72983fafc6
Submitter: Zuul
Branch: master

commit c0e97fcb36d6d12e3c67b100ac189a72983fafc6
Author: Al Bailey <email address hidden>
Date: Thu Oct 17 12:53:41 2019 -0500

    Turn off devstack as a zuul job

    devstack is failing, most likely because StarlingX
    uses postgres, and postgres was dropped in devstack by:
    https://opendev.org/openstack/devstack/commit/cf1c8471910924d154158f78027e46b3e0d3d840

    I am not removing the devstack job declaration, or the devstack files
    because in the future StarlingX could convert from postgres to
    another DB backend, at which point we might want to revisit
    using devstack.

    Change-Id: I02e92cd2d17207b5e09a082647d4da0f5e7ed426
    Partial-Bug: 1848557
    Signed-off-by: Al Bailey <email address hidden>

Reviewed: https://review.opendev.org/689232
Committed: https://git.openstack.org/cgit/starlingx/fault/commit/?id=2f6589751485213d05da4f200be438bc885035c8
Submitter: Zuul
Branch: master

commit 2f6589751485213d05da4f200be438bc885035c8
Author: Al Bailey <email address hidden>
Date: Thu Oct 17 12:49:46 2019 -0500

    Turn off devstack as a zuul job

    devstack is failing, most likely because StarlingX
    uses postgres, and postgres was dropped in devstack by:
    https://opendev.org/openstack/devstack/commit/cf1c8471910924d154158f78027e46b3e0d3d840

    I am not removing the devstack job declaration, or the devstack files
    because in the future StarlingX could convert from postgres to
    another DB backend, at which point we might want to revisit
    using devstack.

    Change-Id: I9dda188aeb32ca07108fed4eabf6716545212dab
    Partial-Bug: 1848557
    Signed-off-by: Al Bailey <email address hidden>

Ghada Khalil (gkhalil) wrote :

stx.3.0 / critical priority - this prevents code from merging

Changed in starlingx:
importance: Undecided → Critical
tags: added: stx.3.0 stx.zuul

Reviewed: https://review.opendev.org/689276
Committed: https://git.openstack.org/cgit/starlingx/update/commit/?id=f0cd0181bc1a6b23768d6976bc0d1b8e1dc7bd0f
Submitter: Zuul
Branch: master

commit f0cd0181bc1a6b23768d6976bc0d1b8e1dc7bd0f
Author: Al Bailey <email address hidden>
Date: Thu Oct 17 16:09:26 2019 -0500

    Turn off devstack as a zuul job

    devstack is failing, most likely because StarlingX
    uses postgres, and postgres was dropped in devstack by:
    https://opendev.org/openstack/devstack/commit/cf1c8471910924d154158f78027e46b3e0d3d840

    I am not removing the devstack job declaration, or the devstack files
    because in the future StarlingX could convert from postgres to
    another DB backend, at which point we might want to revisit
    using devstack.

    Change-Id: Iaac99f28b24609764e7c0cf4750122d765b13420
    Partial-Bug: 1848557
    Signed-off-by: Al Bailey <email address hidden>

Reviewed: https://review.opendev.org/689270
Committed: https://git.openstack.org/cgit/starlingx/ha/commit/?id=6260cb0b748ff2bf3483e86600a7601a4b7b6c62
Submitter: Zuul
Branch: master

commit 6260cb0b748ff2bf3483e86600a7601a4b7b6c62
Author: Al Bailey <email address hidden>
Date: Thu Oct 17 16:07:38 2019 -0500

    Turn off devstack as a zuul job

    devstack is failing, most likely because StarlingX
    uses postgres, and postgres was dropped in devstack by:
    https://opendev.org/openstack/devstack/commit/cf1c8471910924d154158f78027e46b3e0d3d840

    I am not removing the devstack job declaration, or the devstack files
    because in the future StarlingX could convert from postgres to
    another DB backend, at which point we might want to revisit
    using devstack.

    Change-Id: I3adec4669d9181d71421f43905f86bf2e7e211c2
    Partial-Bug: 1848557
    Signed-off-by: Al Bailey <email address hidden>

Al Bailey (albailey1974) wrote :

The four affected repos have all had their fixes merged.

Note: a separate issue is impacting tox/zuul jobs in stx/update related to python imports, I will address that in a separate launchpad.

Changed in starlingx:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers