cgcs-patch tox failing due to missing dependency

Bug #1846244 reported by Don Penney on 2019-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Medium
Don Penney

Bug Description

Brief Description
-----------------

A recent update to sysinv added a new import:
https://review.opendev.org/#/c/679457/7/sysinv/sysinv/sysinv/sysinv/common/utils.py

This file is imported in cgcs-patch and caused a tox failure because it could not be found.

Severity
--------
Minor

Steps to Reproduce
------------------
Run tox

Expected Behavior
------------------
Tox should pass

Actual Behavior
----------------
Tox fails

Reproducibility
---------------
Reproducible

System Configuration
--------------------
Developer repo

Branch/Pull Time/Commit
-----------------------
starlingx/master

Test Activity
-------------
Coding

Reviewed: https://review.opendev.org/686016
Committed: https://git.openstack.org/cgit/starlingx/update/commit/?id=67e9223673355a6242259c8bf38e7d7736153431
Submitter: Zuul
Branch: master

commit 67e9223673355a6242259c8bf38e7d7736153431
Author: Don Penney <email address hidden>
Date: Tue Oct 1 13:29:59 2019 -0400

    Fix cgcs-patch tox failure

    A recent update to sysinv added a new import:
    https://review.opendev.org/#/c/679457/7/sysinv/sysinv/sysinv/sysinv/common/utils.py

    This file is imported in cgcs-patch and caused a tox failure
    because it could not be found. This commit updates the tox.ini and
    .zuul.yaml files to allow for installation of fm-api.

    Change-Id: I12d605d2782f7f32add4428507645cc31caadea2
    Closes-Bug: 1846244
    Signed-off-by: Don Penney <email address hidden>

Changed in starlingx:
status: New → Fix Released
Ghada Khalil (gkhalil) on 2019-10-02
Changed in starlingx:
assignee: nobody → Don Penney (dpenney)
Ghada Khalil (gkhalil) wrote :

Marking as stx.3.0 / medium priority - since this is a zuul failure that was recently introduced.

Changed in starlingx:
importance: Undecided → Medium
tags: added: stx.3.0 stx.update stx.zuul
Al Bailey (albailey1974) wrote :

Another commit has gone in to reintroduce the same type of issue.
I will submit a new launchpad to track it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers