System host-unlock controller-0 fails due to missing package dependencies

Bug #1844394 reported by Cristopher Lemus
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Fix Released
Critical
Erich Cordoba

Bug Description

Brief Description
-----------------
Main controller cannot be unlocked on a fresh install. After the command `system host-unlock controller-0` is executed, the system doesn't reboot.

Severity
--------
Major: Not able to complete a setup.

Steps to Reproduce
------------------
Follow up either wiki or docs to do a new install of starlingx, this happens on all configs. Procedure fails during unlock of main controller.

Expected Behavior
------------------
Main controller is configured and unlocked.

Actual Behavior
----------------
Main controller is configured but remains locked/disabled/online

Reproducibility
---------------
100% reproducble.

System Configuration
--------------------
Simplex, duplex, standard 2+2 and standard 2+2+2.

Branch/Pull Time/Commit
-----------------------
BUILD_ID="20190916T230000Z"

Last Pass
---------
This step passed with previous build: 20190915T230000Z

Timestamp/Logs
--------------
Collect attached for simplex. Some outputs:

http://paste.openstack.org/show/777168/

Test Activity
-------------
Sanity

Revision history for this message
Cristopher Lemus (cjlemusc) wrote :
Revision history for this message
Cristopher Lemus (cjlemusc) wrote :

Also, attached standard (2+2) collect.

Bruce Jones (brucej)
Changed in starlingx:
importance: Undecided → Critical
Revision history for this message
Al Bailey (albailey1974) wrote :

The problem in the puppet manifest log shows that collectd is unable to start because the /usr/lib64/collectd/python.so was missing as a result of this commit
https://review.opendev.org/#/c/653152/

This is fixed by
https://review.opendev.org/#/c/682529/

Revision history for this message
Ghada Khalil (gkhalil) wrote :

Marking as stx.3.0 / critical priority since this is causing a red sanity on stx master.
Assigning to Erich since he introduced and fixed the issue.

Also marking as Fix Released. https://review.opendev.org/#/c/682529/ was merged 2019-09-17 9:41am. It should be in the next cengn build.

Changed in starlingx:
status: New → Triaged
assignee: nobody → Erich Cordoba (ericho)
tags: added: stx.3.0 stx.build
Changed in starlingx:
status: Triaged → Fix Released
Ghada Khalil (gkhalil)
tags: added: stx.sanity
summary: - System host-unlock controller-0 fails
+ System host-unlock controller-0 fails due to missing package
+ dependencies
Revision history for this message
Cristopher Lemus (cjlemusc) wrote :

This issue was fixed with build: 20190918T013000Z

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers