openstack network segment range create failed

Bug #1819541 reported by Juan Carlos Alonso on 2019-03-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
StarlingX
High
Kailun Qin

Bug Description

Title
-----
openstack network segment range create FAILED

Brief Description
-----------------
In “Providernetworking setup: Network Segment Ranges (Stein)” section, in the second command:

$: openstack network segment range create ${PHYSNET0}-b --network-type vlan --physical-network ${PHYSNET0} --minimum 10 --maximum 10 --shared

I got the following error:

BadRequestException: 400: Client Error for url: http://neutron.openstack.svc.cluster.local:80/v2.0/network_segment_ranges, Invalid input for tenant_id. Reason: 'None' is not a valid string.

I tried to add --project ${ADMINID} but --project is only allowed with --private.

Severity
--------
<Critical: System/Feature is not usable after the defect>

Steps to Reproduce
------------------
$: openstack network segment range create ${PHYSNET0}-b --network-type vlan --physical-network ${PHYSNET0} --minimum 10 --maximum 10 --shared

Expected Behavior
------------------
Network segment range created succesfully

Actual Behavior
----------------
BadRequestException: 400: Client Error for url: http://neutron.openstack.svc.cluster.local:80/v2.0/network_segment_ranges, Invalid input for tenant_id. Reason: 'None' is not a valid string.

Reproducibility
---------------
<Reproducible/100%>

System Configuration
--------------------
Any in virtual and Bare Metal environment

tags: added: stx.containers
Ghada Khalil (gkhalil) on 2019-03-12
Changed in starlingx:
assignee: nobody → Kailun Qin (kailun.qin)
importance: Undecided → Critical
tags: added: stx.networking
tags: added: stx.2019.05
Ghada Khalil (gkhalil) on 2019-03-12
tags: removed: stx.containers
Kailun Qin (kailun.qin) wrote :

This is a regression issue due to the requirement change of the network-segment-range OSC CLI during the feature patch review.
I’ve filed bugs [1][2] and submitted patches [3][4] for them.
Please kindly note that [3] would be enough to address this issue, while [4] is an enhancement of semantic check based on the latest alignment on the requirement of network-segment-range OSC CLI behavior.

[1] https://storyboard.openstack.org/#!/story/2005205
[2] https://storyboard.openstack.org/#!/story/2005206
[3] https://review.openstack.org/#/c/642707/
[4] https://review.openstack.org/#/c/642708/

Ghada Khalil (gkhalil) wrote :

This issue was introduced in StarlingX on March 8 after picking up the latest openstack client code which included the following commit related to network segment range:
https://github.com/openstack/python-openstackclient/commit/6868499ad9443960a158143c923da00ea86b7072

See https://bugs.launchpad.net/starlingx/+bug/1819176 for more details.

It appears that the network segment range code was changed before the merge and is now causing issues. Subsequent code changes are required in the openstack client code to address the issue. These are tracked by the following:
https://storyboard.openstack.org/#!/story/2005205
https://storyboard.openstack.org/#!/story/2005206
https://review.openstack.org/#/c/642707/
https://review.openstack.org/#/c/642708/

Ghada Khalil (gkhalil) wrote :

Workaround: Do not specify --shared and it’ll default to a shared range.

Changed in starlingx:
status: New → In Progress
Ghada Khalil (gkhalil) on 2019-03-12
tags: added: stx.distro.openstack

Workaround works correctly on our side.

Kailun Qin (kailun.qin) wrote :

The issue was not discovered due to a functional test bug [1] in openstackclient. The functional test for network segment range was skipped unexpectedly because of this.
Now we've added tests at unit level [2] to have it covered.

[1] https://review.openstack.org/#/c/642074/
[2] https://review.openstack.org/#/c/642707/

Kailun Qin (kailun.qin) wrote :

The fix which directly addresses this issue [1] has been merged into python-openstackclient already.

[1] https://review.openstack.org/#/c/642707/

Ghada Khalil (gkhalil) wrote :

Reducing the priority to high since there is a workaround

Changed in starlingx:
importance: Critical → High
Ghada Khalil (gkhalil) wrote :

The openstack-client code has merged as of March 15:
https://review.openstack.org/#/c/642707/
https://review.openstack.org/#/c/642708/
https://review.openstack.org/#/c/642074/

There is also a starlingx review to pick up master openstack-client when building the wheels:
https://review.openstack.org/#/c/644381/

Ghada Khalil (gkhalil) wrote :

https://review.openstack.org/#/c/644381/ is included in cengn build: 20190318T233000Z

Kailun Qin (kailun.qin) on 2019-03-19
Changed in starlingx:
status: In Progress → Fix Released
Ken Young (kenyis) on 2019-04-05
tags: added: stx.2.0
removed: stx.2019.05
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers