config_controller: Populating Initial System Inventory failed

Bug #1811473 reported by Juan Carlos Alonso on 2019-01-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Juan Carlos Alonso

Bug Description

Title
-----

config_controller: Populating Initial System Inventory failed

Brief Description
-----------------

During config_controller, step 04/08 failed:

Applying configuration (this will take several minutes):

01/08: Creating bootstrap configuration ... DONE
02/08: Applying bootstrap manifest ... DONE
03/08: Persisting local configuration ... DONE
04/08: Populating initial system inventory ... No handlers could be found for logger "cgtsclient.common.http"

Entire log attached below.

Severity
--------

<Critical: System/Feature is not usable after the defect>

Steps to Reproduce
------------------

python runner.py --run-suite Setup --environment virtual --configuration {3,4}

Expected Behavior
-----------------

config_controller pass
Configuration Applied

Actual Behavior
----------------

config_controller failed

Reproducibility
---------------

<Reproducible/100%>

System Configuration
--------------------

Virtual Environment:
  - Multinode Local Storage
  - Multinode External Storage

Al Bailey (albailey1974) wrote :

I believe this is because of this pair of commits which require a larger initial disk
 (stx-config commit merged on Jan 10) fails if the disk is not large enough

https://github.com/openstack/stx-config/commit/6da46d861bd16cf4441ba107fb178c154a8c7f57

However those commits were only supposed to impact a build that is configured for containers/kubernetes

Al Bailey (albailey1974) wrote :

That commit sets MINIMUM_DISK_SIZE = 201

https://github.com/openstack/stx-config/commit/6da46d861bd16cf4441ba107fb178c154a8c7f57#diff-d587e0e7d7964c20e31a052267a50286

The disks configured in virtual box need to be increased and wikis updated.

The test suite had 200GB and the minimun now is 201GB.
After increase the size to 250GB config_controller passed.

Applying configuration (this will take several minutes):

01/08: Creating bootstrap configuration ... DONE
02/08: Applying bootstrap manifest ... DONE
03/08: Persisting local configuration ... DONE
04/08: Populating initial system inventory ... DONE
05/08: Creating system configuration ... DONE
06/08: Applying controller manifest ... DONE
07/08: Finalize controller configuration ... DONE
08/08: Waiting for service activation ... DONE

Configuration was applied

Ghada Khalil (gkhalil) wrote :

Marking as release gating as this issue caused a red sanity.

As noted above, the minimum disk was increased recently. This requires the vbox setup and automated test suite to be updated accordingly.

Assigning back to Juan to update the automated test suite accordingly. Please mark as Fix Released when the test suite is updated.

tags: added: stx.2019.03 stx.test
Changed in starlingx:
importance: Undecided → Critical
Ghada Khalil (gkhalil) on 2019-01-12
Changed in starlingx:
assignee: nobody → Juan Carlos Alonso (juancarlosa)
status: New → Triaged
Changed in starlingx:
status: Triaged → In Progress

The commit says that this update affect only to worker nodes, but during test we need to increase the size of all VMs created to assure a good configuration. Is this a good behavior?

Changed in starlingx:
status: In Progress → Fix Released
Wei Zhou (wzhou007) wrote :

There are two commits went in.
https://github.com/openstack/stx-metal/commit/fe397d5d276dfb9dd979216b7ab54be17c7b6e89
https://github.com/openstack/stx-config/commit/6da46d861bd16cf4441ba107fb178c154a8c7f57

Because docker-lv size is increased to 30GB for all the nodes, the default root disk size for all the nodes are increased.

Ken Young (kenyis) on 2019-01-18
tags: added: stx.2019.05
removed: stx.2019.03
Ken Young (kenyis) on 2019-04-05
tags: added: stx.2.0
removed: stx.2019.05
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers