STX: config_controller failed to execute controller manifest

Bug #1800466 reported by Peng Peng on 2018-10-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Al Bailey

Bug Description

Brief Description
-----------------
config_controller failed at Applying controller manifest

Severity
--------
Critical

Steps to Reproduce
------------------
sudo -S config_controller --config-file TiS_config.ini_centos

Expected Behavior
------------------
config successfully

Actual Behavior
----------------
config failed

Reproducibility
---------------
Reproducible 100%

System Configuration
--------------------
all kinds of system

Branch/Pull Time/Commit
-----------------------
master as of 2018-10-26_20-18-00

Timestamp/Logs
--------------
(2018-10-29 04:38:47) [INFO] [MainThread] echo Li69nux* | sudo -S config_controller --config-file TiS_config.ini_centos
(2018-10-29 04:53:04) [INFO] [MainThread] Output:
iS_config.ini_centos
Parsing system configuration file... DONE
Validating system configuration file... DONE
Creating config apply file... DONE

The following configuration will be applied:

System Configuration
--------------------
Time Zone: UTC
System mode: simplex

PXEBoot Network Configuration
-----------------------------
Separate PXEBoot network not configured
PXEBoot Controller floating hostname: pxecontroller

Management Network Configuration
--------------------------------
Management interface name: lo
Management interface: lo
Management interface MTU: 1500
Management interface link capacity Mbps: 10000
Management subnet: 127.168.204.0/24
Controller floating address: 127.168.204.2
Controller 0 address: 127.168.204.3
Controller 1 address: 127.168.204.4
NFS Management Address 1: 127.168.204.5
NFS Management Address 2: 127.168.204.6
Controller floating hostname: controller
Controller hostname prefix: controller-
OAM Controller floating hostname: oamcontroller
Dynamic IP address allocation is selected
Management multicast subnet: 239.1.1.0/28

Infrastructure Network Configuration
------------------------------------
Infrastructure interface not configured

External OAM Network Configuration
----------------------------------
External OAM interface name: enp3s0f0
External OAM interface: enp3s0f0
External OAM interface MTU: 1500
External OAM subnet: 128.224.150.0/23
External OAM gateway address: 128.224.150.1
External OAM address: 128.224.151.33

Applying configuration (this will take several minutes):

01/08: Creating bootstrap configuration ... DONE
02/08: Applying bootstrap manifest ... DONE
03/08: Persisting local configuration ... DONE
04/08: Populating initial system inventory ... DONE
05/08: Creating system configuration ... DONE
06/08: Applying controller manifest ... Failed to execute controller manifest

Ghada Khalil (gkhalil) on 2018-10-29
Changed in starlingx:
importance: Undecided → Critical
assignee: nobody → Al Bailey (albailey1974)
tags: added: stx.config
Ghada Khalil (gkhalil) wrote :

From Don Penney:
There is a failure running neutron-db-sync:

2018-10-29T04:47:29.592 Notice: 2018-10-29 04:47:29 +0000 /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]/returns: oslo_db.exception.DBError: (psycopg2.ProgrammingError) syntax error at or near "SELECT"
2018-10-29T04:47:29.594 Notice: 2018-10-29 04:47:29 +0000 /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]/returns: LINE 1: CREATE TEMPORARY TABLE TEMP_SUBNETS (SELECT s.id FROM subnet...
2018-10-29T04:47:29.596 Notice: 2018-10-29 04:47:29 +0000 /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]/returns: ^
2018-10-29T04:47:29.598 Notice: 2018-10-29 04:47:29 +0000 /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]/returns: [SQL: 'CREATE TEMPORARY TABLE TEMP_SUBNETS (SELECT s.id FROM subnets AS s LEFT OUTER JOIN ipallocations AS ia ON ia.subnet_id = s.id WHERE s.managed = false GROUP BY s.id,ia.ip_address HAVING COUNT(ia.ip_address) = 0);']
2018-10-29T04:47:29.600 Error: 2018-10-29 04:47:29 +0000 /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: Failed to call refresh: neutron-db-manage upgrade heads returned 1 instead of one of [0]
2018-10-29T04:47:29.602 Error: 2018-10-29 04:47:29 +0000 /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: neutron-db-manage upgrade heads returned 1 instead of one of [0]

tags: added: stx.2019.03
Ghada Khalil (gkhalil) wrote :

It appears that the issue is introduced by this commit:
https://github.com/starlingx-staging/stx-neutron/commit/62b16547d9994a91768ba78546006da6a51764f2

which was merged on October 26/2018

Changed in starlingx:
status: New → Triaged
Al Bailey (albailey1974) wrote :
Changed in starlingx:
status: Triaged → Fix Committed
Ghada Khalil (gkhalil) on 2018-10-30
Changed in starlingx:
status: Fix Committed → Fix Released
Ken Young (kenyis) on 2019-01-18
tags: added: stx.2019.05
removed: stx.2019.03
Ken Young (kenyis) on 2019-04-05
tags: added: stx.2.0
removed: stx.2019.05
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers