Simplex-Virtual, Nova-compute with Status=disable and State=down/degraded

Bug #1797474 reported by Maria Guadalupe Perez Ibara on 2018-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
High
Steven Webster

Bug Description

Title
-----
Nova-compute with Status=disable and State=down

Brief Description
-----------------
Nova-compute does not start by its own, while trying to enable manually, it just change the Status to enable but State remains down, and availability is degraded.

Severity
--------
Critical

Steps to Reproduce
------------------
1.- Configure Provider Networks
2.- Provide Data Interface on Controller-0
3.- Configure Cinder on Controller Disk
4.- Configure VM Local Storage on Controller Disk
5.- Add LVM Storage Backend
6.- Unlock controller-0
7.- Verify the controller-0 configuration by nova service-list
8.- verify system host-list

Expected Behavior
------------------
Nova-compute should be Status: Enabled
system host-list availability : available
Actual Behavior
----------------
Nova-compute shows as Status : Down
system host-list availability, "available State" : Degraded

Reproducibility
---------------
Reproducible 100% in Simplex - Virtual

System Configuration
--------------------
Simplex Bare Metal
iso : stx-2018-10-03-11-r-2018.10.iso

Branch/Pull Time/Commit
-----------------------
stx-tools

Ada Cabrales (acabrale) wrote :

This is similar to https://bugs.launchpad.net/starlingx/+bug/1796420, but specific for virtual environment.

tags: added: stx.2018.10
Ghada Khalil (gkhalil) on 2018-10-12
Changed in starlingx:
importance: Undecided → High
tags: added: stx.networking
Changed in starlingx:
assignee: nobody → Steven Webster (swebster-wr)
Ghada Khalil (gkhalil) wrote :

Ada/Maria, please track this issue against https://bugs.launchpad.net/starlingx/+bug/1796380 which I've tagged for stx.2018.10

Juan Pablo Gomez (jpgomez) wrote :

Ghada also this issue is reproducible for virtual Duplex Environment, nova-compute is disable and down

Ghada Khalil (gkhalil) wrote :

Duplicate of https://bugs.launchpad.net/starlingx/+bug/1796380
Marking as Fix Released; same as the duplicate launchpad. The fix was merged on 2018-10-19

Changed in starlingx:
status: New → Fix Released
Ken Young (kenyis) on 2019-04-06
tags: added: stx.1.0
removed: stx.2018.10
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers