Controller-1 and Computes cannot unlock due to missing inventory

Bug #1795466 reported by Juan Carlos Alonso on 2018-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StarlingX
Critical
Don Penney

Bug Description

Title
-----

Controller-1 anc Computes did not install correctly, they do not have network interfaces.

Brief Description
-----------------

After provision and unlock of Controller-0, proceed with the installation of Controller-1.
Seems that installation finished correctly but when start to provisioning found that it does not have network interfaces. If Controller-1 is not full provisoned it cannot be unlocked nor used.
The same behaviour on Compute-0 and Compute-1.

Severity
--------

Critical: Controller-1, Compute-0 and Compute-1 cannot be provisioned.

Steps to Reproduce
------------------

After installation and unlock of Controller-0

To add and install Controller-1:
$ system host-update 2 personality=controller hostname=controller-1
or
$ system host-add -n controller-1 -p controller -m ${mac_address}

To add and install Compute-0:
$ system host-update 3 personality=compute hostname=compute-0
or
$ system host-add -n compute-0 -p compute -m ${mac_address}

To add and install Compute-1:
$ system host-update 4 personality=compute hostname=compute-1
or
$ system host-add -n compute-1 -p compute -m ${mac_address}

Expected Behavior
-----------------

After installation of Controller-1 and Computes, and reboot is completed the controller and computes should be reported as Locked, Disabled, and Online.

Also they need to have nerwork interfaces to start provisioning:
$ system host-if-list -a [ controller-1 | compute-N ]
+--------------------------------------+---------+----------+----------+---------+
| uuid | name | class | type | vlan id |
+--------------------------------------+---------+----------+----------+---------+
| 1fd0728c-0e22-4f01-986b-d127fad943d8 | ens7 | platform | ethernet | None |
| 48474ad8-4f19-44f7-b84c-c2facaabfb7d | ens6 | platform | ethernet | None |
| 688f458a-76ae-4f85-9b7a-93bd41f3c83f | eth1000 | None | ethernet | None |
| 9f3b613c-0e6e-4731-a806-c062388cc717 | eth1001 | None | ethernet | None |
+--------------------------------------+---------+----------+----------+---------+

Actual Behavior
----------------

There are not network interfaces in Controller-1 nor Compute-N:
$ system host-if-list -a [ controller-1 | compute-N ]
---

Reproducibility
---------------

100 %

System Configuration
--------------------

Virtual Multi-node Controller Storage

Ghada Khalil (gkhalil) wrote :

Please run the collect tool on controller-0 to gather the logs from the system and attach them to the launchpad.
On controller-0 >> collect all

Changed in starlingx:
status: New → Incomplete
Ghada Khalil (gkhalil) wrote :

This is the same issue as reported in https://bugs.launchpad.net/starlingx/+bug/1795400
Tagging for stx.2018.10 as the issue is blocking system configuration

Changed in starlingx:
importance: Undecided → Critical
status: Incomplete → Triaged
tags: added: stx.confi
tags: added: stx.config
removed: stx.confi
tags: added: stx.2018.10
summary: - Controller-1 and Computes did not install correctly.
+ Controller-1 and Computes cannot unlock due to missing inventory
Changed in starlingx:
assignee: nobody → Don Penney (dpenney)
Ghada Khalil (gkhalil) wrote :

Duplicate of https://bugs.launchpad.net/starlingx/+bug/1795400
Marking as Fix Released; same as the duplicate bug report. The fix was merged in 2018-10-02

Changed in starlingx:
status: Triaged → Fix Released
Ken Young (kenyis) on 2019-04-06
tags: added: stx.1.0
removed: stx.2018.10
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers