Horizon sends "Error: Unable to retrieve alarm summary"

Bug #1790718 reported by Elio Martinez on 2018-09-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
StarlingX
Medium
Tao Liu

Bug Description

Title
-----
Horizon sends: "Error: Unable to retrieve alarm summary"

Brief Description
-----------------
After installing controller 1 in multinode virtual configuration, after config_controller installation, as soon as Horizon is alive and running on the internet explorer, pop-ups showing "Error: Unable to retrieve alarm summary" appear all along the screen. The only way to get rid of that messages is to refresh the website.

Getting into Admin--> Platform--> Fault Management sends:

StarlingX

"Soemthing went wrong!"

Severity
--------

<Minor: System/Feature is usable with minor issue>

Steps to Reproduce
------------------
Deploy your multinode configuration
Instal Iso on you controller
In your controller execute : "$sudo config_controller"
Launch Horizon

Expected Behavior
------------------
Fault management should be available, no pop-ups on screen

Actual Behavior
----------------
Pop-ups with the mentioned error, fault management not available

Reproducibility
---------------
100%

System Configuration
--------------------
Multinode configuration, 2 controller, 2 computes

Branch/Pull Time/Commit
-----------------------
stx-2018-08-22-76.iso

Timestamp/Logs
--------------
Attached screen-shots and fm and sm log

Elio Martinez (elio1979) wrote :

Attaching logs and images

Ghada Khalil (gkhalil) on 2018-09-05
Changed in starlingx:
assignee: nobody → Tao Liu (tliu88)
tags: added: stx.2018.10 stx.fault stx.gui
Ghada Khalil (gkhalil) wrote :

This should not be a problem if stx-gui is loaded manually on the system. There is a task in progress to allow stx-gui to be loaded automatically by the system:
Story: https://storyboard.openstack.org/#!/story/2002891
Task: 24821

Assigning to Tao to confirm. Once confirmed, this bug can be marked as Merged based on the commits associated with the above task.

Changed in starlingx:
importance: Undecided → Medium
status: New → Triaged
Tao Liu (tliu88) wrote :

Yes, Ghada is correct. The horizon fault management interfaces are now in stx-gui. Currently stx-gui needs to be loaded manually with horizon that has fault management and other extension removed.

Tested last iso "stx-2018-09-13-113.iso", the issue is not present.

Ghada Khalil (gkhalil) wrote :
Changed in starlingx:
status: Triaged → Fix Released
Ken Young (kenyis) on 2019-04-06
tags: added: stx.1.0
removed: stx.2018.10
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments