Pagination filter completely ignores standard filter.

Bug #926983 reported by Nathan Osman on 2012-02-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stack.PHP
High
Nathan Osman

Bug Description

Example scenario:

1. User creates a filter for a request with specific items included.
2. User creates the request, obtains a response, and calls response->Total().
3. Because Total() uses the paginated filter, the included items are ignored since the default paginated filter is used.

This can result in the wrong items being returned. A possible workaround is to have the URL class keep track of both filters if needed.

Nathan Osman (george-edison55) wrote :

I have now committed a possible fix for this issue - the URL::SetFilter (and PagedRequest::Filter) method now accepts two filters - the first is the filter to use by default for all requests and the second (optional) filter specifies a custom filter for requests that need access to the total number of items.

Changed in stackphp:
status: Confirmed → Fix Committed
Changed in stackphp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers