Unknown Error when Accessing Nonexistant User Info

Bug #808147 reported by Thomas Ward on 2011-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
StackApplet
Low
Nathan Osman
stackapplet (Ubuntu)
Low
Unassigned

Bug Description

I noticed this when I recovered my StackApplet configs from my previous OS install. This config included a user from a closed beta of a StackExchange Site, and that user data was removed when it was shut down. The system says "Unknown Error" in place of a nonexistent user.

Is this a bug, or is this by-design? If it is a bug, could it be written to be saying "Unknown User" rather than "Unknown Error"?

Attached is a screenshot to show the issue.

OS: Ubuntu 11.04 (Natty), 64bit

Thomas Ward (teward) wrote :
description: updated
description: updated
Nathan Osman (george-edison55) wrote :

Yes, the error description should be a little clearer. I will take a look at that and see if I can change it to 'unknown user'... although in your case the problem is that the site is gone so it should really say 'unknown site'.

Changed in stackapplet:
assignee: nobody → George Edison (george-edison55)
importance: Undecided → Low
status: New → Confirmed
Thomas Ward (teward) on 2011-07-09
Changed in stackapplet (Ubuntu):
status: New → Invalid
Thomas Ward (teward) on 2011-07-09
Changed in stackapplet (Ubuntu):
status: Invalid → Confirmed
Changed in stackapplet (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments