[SRU] Add support to import multiple keys

Bug #1565275 reported by Mitsuya Shibata on 2016-04-02
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ssh-import-id
High
Dustin Kirkland 
ssh-import-id (Ubuntu)
High
Dustin Kirkland 

Bug Description

Please upgrade xenial/ssh-import-id package from 5.5 to 5.6 (already in yakkety, bugfix minor update).

[Impact]

 * If there are multiple keys in GitHub, then ssh-import-id import a lastkey entry only.

 * This is regression from older release (before wily).

[Test Case]

 * Add multiple public ssh keys to GitHub.
   Example: https://api.github.com/users/m-shibata/keys

 * Import ssh keys by ssh-import-id.
   Example: $ ssh-import-id gh:m-shibata

 * Check there are all keys in ~/.ssh/authorized_keys
   Example: $ cat ~/.ssh/authorized_keys

[Regression Potential]

 * Probably no.

 * Affects only import github keys.

Related branches

Scott Moser (smoser) on 2016-04-04
Changed in ssh-import-id:
importance: Undecided → High
status: New → Confirmed
Mitsuya Shibata (cosmos-door) wrote :

Unfortunately I have not received upstream's reply about this merge request.
However yakkety beta freeze is approaching.

I attach patch to fix this bug for ssh-import-id for *Ubuntu* package
as workaround until upstream release.

Would you review it?

Changed in ssh-import-id (Ubuntu):
status: New → In Progress
Mitsuya Shibata (cosmos-door) wrote :
tags: added: regression-release xenial
Changed in ssh-import-id (Ubuntu):
importance: Undecided → High
Changed in ssh-import-id (Ubuntu):
status: In Progress → Confirmed
Dustin Kirkland  (kirkland) wrote :

Hmm, I'm unable to reproduce this bug.

I just tried:

$ ssh-import-id -o - kirkland smoser > /tmp/out

And got both kirkland's and smoser's keys.

That's with ssh-import-id version 5.5-0ubuntu1.

Changed in ssh-import-id:
status: Confirmed → Incomplete
Changed in ssh-import-id (Ubuntu):
status: Confirmed → Incomplete
Dustin Kirkland  (kirkland) wrote :

Ah, I see. This only affects github. And I only had 1 key in github. I've now reproduced the problem.

Changed in ssh-import-id:
status: Incomplete → In Progress
Changed in ssh-import-id (Ubuntu):
status: Incomplete → In Progress
Changed in ssh-import-id:
assignee: nobody → Dustin Kirkland  (kirkland)
Changed in ssh-import-id (Ubuntu):
assignee: nobody → Dustin Kirkland  (kirkland)
Dustin Kirkland  (kirkland) wrote :

And verified the fix.

Dustin Kirkland  (kirkland) wrote :

Okay, I'm just cherry-picking the fix for __init_.py and releasing it.

Dustin Kirkland  (kirkland) wrote :

Okay, fix committed, and released in ssh-import-id 5.6, and uploaded to yakkety.

Dustin Kirkland  (kirkland) wrote :

This would need an SRU to get released in Xenial.

Changed in ssh-import-id:
status: In Progress → Fix Released
Changed in ssh-import-id (Ubuntu):
status: In Progress → Fix Released
Mitsuya Shibata (cosmos-door) wrote :

Hi Dustin,

Thank you for uploading!

> This would need an SRU to get released in Xenial.

Indeed. I will prepare SRU in next week. Thanks!

description: updated
summary: - Add support to import multiple keys
+ [SRU] Add support to import multiple keys
Mitsuya Shibata (cosmos-door) wrote :

Added debdiff.

Mike Rushton (leftyfb) wrote :

I noticed this never got SRU'd. Oversight?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers