Search feature not working

Reported by prash_n_rao on 2011-03-25
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Sphinx
Fix Released
Undecided
Unassigned
jquery (Ubuntu)
Undecided
Unassigned
sphinx (Debian)
Fix Released
Unknown
sphinx (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python2.7-doc

* Open the link to python docs (file:///usr/share/doc/python2.7/html/index.html) in a browser (tested with firefox and google-chrome)
* Entered a term in the "Quick Search" field
* Press "Go"

3) What you expected to happen
Up to Ubuntu 10.10, I would get a list of all pages that contain the term

4) What happened instead
Pressing "Go" takes me to a page that says:
Preparing search...

Searching...
(with the number of dots increasing to three and then jumping back to zero, cyclically)

This happens with python3.2-doc as well.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-doc 2.7.1-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Fri Mar 25 12:06:20 2011
Dependencies:
 libjs-jquery 1.5-2ubuntu1
 python2.7-doc 2.7.1-5ubuntu1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110302)
ProcEnviron:
 LANGUAGE=en_IE:en
 PATH=(custom, user)
 LANG=en_IE.UTF-8
 SHELL=/bin/zsh
SourcePackage: python-defaults
UpgradeStatus: No upgrade log present (probably fresh install)

Matthias Klose (doko) on 2011-04-04
tags: added: python27
Barry Warsaw (barry) wrote :

This appears to be a problem with the _static/jquery.js link. If I replace the link with the jquery.js from the Python 2.7 upstream source tree, it works fine. I think we should not try to save a little space and just use upstream's jquery.js.

Barry Warsaw (barry) wrote :

Note that this is not limited to Python 2.7. python3.1-doc and python3.2-doc are also affected.

jquery.js comes from Sphinx and it is the policy of sharing this file which is causing the problem, because it is incompatible with the Python docs, for some reason not yet determined.

Barry Warsaw (barry) wrote :

I've verified that using the jquery.js from Sphinx fixes the problem, however it is Debian policy to share this file from libjs-jquery. The version in Natty is incompatible with Sphinx's output of the Python docs. I don't know why though.

affects: python2.7 (Ubuntu) → jquery (Ubuntu)
Barry Warsaw (barry) wrote :
Changed in sphinx:
status: New → Confirmed
tags: removed: python27
Barry Warsaw (barry) wrote :

Anyway, the fix described there (setting HAS_SOURCE: false in search.html) does not work for me on Natty. Probably the best thing to do is report the bug upstream and see if Georg has any ideas.

Barry Warsaw (barry) wrote :

This has now been resolved upstream, so it's worth addressing this issue for Oneiric (and possibly backporting for Natty).

Gediminas Paulauskas (menesis) wrote :

The upstream Sphinx fix is in unreleased version 1.0.8, see http://sphinx.pocoo.org/changes.html

Changed in sphinx (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jquery (Ubuntu):
status: New → Confirmed
Changed in sphinx:
status: Confirmed → Fix Released
Phil Grohe (phil-grohe) wrote :

Forgive my ignorance but after reading all of the above I still don't know how to get the search working for the python2.7-doc package.

I just installed that package on a fresh 11.10 install and I'm still seeing the bug described here. I've checked for updates in the Update Manger and none are available.

Basically, how do I get the fix that this bug says exists for this issue?

I do see sphinx related package named 'libjs-sphinxdoc', is this what I need?

Gediminas Paulauskas (menesis) wrote :

The fix mentioned in Comment #6 was applied in 1.0.7-4 and is in Oneiric, also in the python2.7-doc package.

However, the search feature still does not work... In Chrome: https://bitbucket.org/birkenfeld/sphinx/issue/723/search-broken-in-webkit-based-browsers

Search does work in Firefox, try file:///usr/share/doc/python2.7/html/search.html?q=unittest

Only file:/// location has this problem, if you have apache2 installed, this works both in Chrome and Firefox: http://localhost/doc/python2.7/html/search.html?q=unittest

Phil Grohe (phil-grohe) wrote :

Awesome, thank you.

Urs Fleisch (ufleisch) wrote :

Fresh install of Ubuntu 12.04 Beta plus updates: The Python search does not work.

Urs Fleisch (ufleisch) wrote :

Investigating further why the Python search is not working in Ubuntu 12.04, I found out that it is not a bug in jquery, but in python2.7-doc, so I opened a new bug there: https://bugs.launchpad.net/ubuntu/+source/python2.7/+bug/1001585.

Changed in sphinx (Debian):
status: Unknown → Fix Committed
Dmitry Shachnev (mitya57) wrote :

Closing this bug as the original Sphinx issue (https://bitbucket.org/birkenfeld/sphinx/issue/682/sphinx-101-and-jquery-15-incompatibility) is fixed in v1.0.8.

There is a remaining issue in WebKit-based browsers, but this is not related to this bug report: https://bitbucket.org/birkenfeld/sphinx/issue/723/search-broken-in-webkit-based-browsers.

Changed in sphinx (Ubuntu):
status: Confirmed → Fix Released
Changed in jquery (Ubuntu):
status: Confirmed → Invalid
Changed in sphinx (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.