No property "profile"-error when converting to AAC

Bug #954555 reported by Patrick Steinhardt on 2012-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
High
GautierPortet
soundconverter (Ubuntu)
Undecided
Unassigned

Bug Description

When converting MP3 files to AAC, the following error is reported for each element that should be converted.

Error: GStreamer error when creating pipeline
no property "profile" in element "faac0"

Versions:

ArchLinux
gstreamer0.10.36
soundconverter 2.0.1

The error came up just recently, I think with the update to latest gstreamer.

Related branches

lp:~logan/ubuntu/raring/soundconverter/new-upstream
Ubuntu branches: Pending requested 2012-11-21
description: updated

I did some research on the issue. It looks like "[faac] AAC profile support in the caps" (https://bugzilla.gnome.org/show_bug.cgi?id=650594) might be related to this, as this ticket was done for GStreamer -Bad 0.10.36. But I'm not sure at all, I'm not comfortable with audio codecs.

GautierPortet (kassoulet) wrote :

Well, this is maybe a temporary breakage of gstreamer...
Anyway, soundconverter tells faac to use the low complexity profile, but this is now the default (as of 0.10.35), so you can experiment, and remove the "profile=2" in soundconverter/gstreamer.py, line 654 and see what happens.

I already figured out that removing profile=2 fixed my problem yesterday. I was a little bit surprised though that the averaged bitrate of the resulting files was around 150kbps then, as I chose 256kpbs. So I thought removing profile=2 wasn't really what I want.

Arnie (swapnil-bhartiya) wrote :

How to edit soundconverter/gstreamer.py where is it located?

GautierPortet (kassoulet) wrote :

In the source archive.

zebul666 (zebul666) wrote :

It is still there with soundconverter 2.03 and latest gstreamer, archlinux current x86_64

gstreamer0.10 0.10.36-1
gstreamer0.10-bad 0.10.23-2
gstreamer0.10-bad-plugins 0.10.23-2
gstreamer0.10-base 0.10.36-1
gstreamer0.10-base-plugins 0.10.36-1
gstreamer0.10-ffmpeg 0.10.13-1
gstreamer0.10-good 0.10.31-1
gstreamer0.10-good-plugins 0.10.31-1
gstreamer0.10-python 0.10.22-1
gstreamer0.10-ugly 0.10.19-2
gstreamer0.10-ugly-plugins 0.10.19-2
gstreamermm 0.10.10-1

GautierPortet (kassoulet) wrote :

Cannot reproduce, I remove profile=2 from command anyway as it's not useful anymore.

Changed in soundconverter:
importance: Undecided → High
assignee: nobody → GautierPortet (kassoulet)
milestone: none → 2.0.4
status: New → Fix Committed
Changed in soundconverter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package soundconverter - 2.0.4-0ubuntu1

---------------
soundconverter (2.0.4-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1077508).
    - Disable common path when creating folders using tags (LP: #972158).
    - Increase Low pass filter frequency when converting to MP3 (LP: #881413).
    - Use original filename as title when tags are not present (LP: #984790).
    - Fix command line arguments parsing (LP: #995862).
    - Fix problem with AAC settings (LP: #954555).
    - Fix yet another problem with URIs handling (LP: #998371).
 -- Logan Rosen <email address hidden> Wed, 21 Nov 2012 12:38:13 -0500

Changed in soundconverter (Ubuntu):
status: New → Fix Released
Teresa e Junior (teresaejunior) wrote :

I removed profile=2, and can reproduce that the quality settings are completely ignored. The produced m4a files are set 128k regardless of what the user chooses.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.