tags not detected at first with m4a

Bug #1883257 reported by sezanzeb on 2020-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Undecided
Unassigned

Bug Description

Hi,

When I set the output format to AAC/m4a, no tags are added to the output file. The path will also be Unknown_Artist/Unknown_Album/

I figured out that on_message in gstreamer.py does not receive the tags message (https://github.com/kassoulet/soundconverter/blob/py3k/soundconverter/gstreamer.py#L229)

I can change the format to mp3 and convert it, and it will. Afterwards the tags also work for m4a. I guess because they were added to the soundfile at that point during append_tag (https://github.com/kassoulet/soundconverter/blob/py3k/soundconverter/gstreamer.py#L411)

See the attachment. Those messages come from gstreamer right? Is there anything we can do?

sezanzeb (sezanzeb) wrote :
sezanzeb (sezanzeb) wrote :

I forced 'avenc_aac' instead of 'faac' by overwriting add_aac_encoder, but I get the same result. Reading from tags should be independent of that anyways, right? How can the output format change the ability to read tags when the input format remains flac in both cases.

sezanzeb (sezanzeb) wrote :

updating all my gstreamer packages to 1.16.2-2 did not solve the issue (manjaro).

sezanzeb (sezanzeb) wrote :

For all other formats it works as well. It only doesn't work for m4a

sezanzeb (sezanzeb) wrote :

*For all other output formats

I just tried other files with .opus and .m4a extensions as input, but get the same results. mp3 output gets the tag message, m4a output not.

It's really only when the output is set to m4a.

sezanzeb (sezanzeb) wrote :

--gst-debug-level=3 gives me:

0:00:12.118306757 67690 0x55e196f47400 WARN audioencoder gstaudioencoder.c:965:gst_audio_encoder_finish_frame:<faac0> Can't copy metadata because input buffer disappeared

(now possible with https://github.com/kassoulet/soundconverter/pull/34)

sezanzeb (sezanzeb) wrote :

see https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues/759

working on a fix and going to make a PR on this soon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.