Soundconverter thinks all my flac files are "unkown artist" when creating artist directory

Bug #1863048 reported by davidudin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Medium
GautierPortet

Bug Description

soundconverter --debug
SoundConverter 3.0.0
  using GTK version: 3.0
  using Gstreamer version: 1.14.5.0
  using gio
  "faac" gstreamer element not found, disabling AAC output.
/usr/share/soundconverter/python/soundconverter/ui.py:1406: Warning: g_value_type_transformable: assertion 'G_TYPE_IS_VALUE (src_type)' failed
  builder.add_from_file(gladefile)

(python3:21617): Gtk-WARNING **: 23:36:12.770: ../../../../gtk/gtkliststore.c:836: Unable to convert from (null) to gchararray
adding: 0 files
Added 0 files in 0.00s (scan 0.00s, add 0.00s)

running on Linux Mint 19.3 Cinnamon

checking the tags with kid3 showed them present and correct, created by asunder, which also created the appropriate directory structure artist/album/...

Revision history for this message
davidudin (david-udin) wrote :
Revision history for this message
davidudin (david-udin) wrote :

I just checked, and the artist tag in the output mp3 is ok. The problem is just in the output directory structure. It also claims unknown artist if I use artist-album output format instead of artist/album.

Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
importance: Undecided → Medium
Revision history for this message
GautierPortet (kassoulet) wrote :

Thank you for the report.

This issue was fixed in 2018, and released in SoundConverter 3.0.1.
 - https://github.com/kassoulet/soundconverter/commit/c7cdbd4ecd8c27470bc06f650839686644104bc5

You can update your version to fix the problem.

Changed in soundconverter:
status: New → Fix Released
milestone: none → 3.0.1
Revision history for this message
davidudin (david-udin) wrote : Re: [Bug 1863048] Re: Soundconverter thinks all my flac files are "unkown artist" when creating artist directory

Thanks. Looks like Ubuntu didn't update their repository. Guess I'll have
to compile the new version.

Cheers,

David

On Fri, Apr 17, 2020 at 4:01 AM GautierPortet <email address hidden> wrote:

> Thank you for the report.
>
> This issue was fixed in 2018, and released in SoundConverter 3.0.1.
> -
> https://github.com/kassoulet/soundconverter/commit/c7cdbd4ecd8c27470bc06f650839686644104bc5
>
> You can update your version to fix the problem.
>
>
> ** Changed in: soundconverter
> Status: New => Fix Released
>
> ** Changed in: soundconverter
> Milestone: None => 3.0.1
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1863048
>
> Title:
> Soundconverter thinks all my flac files are "unkown artist" when
> creating artist directory
>
> Status in SoundConverter:
> Fix Released
>
> Bug description:
> soundconverter --debug
> SoundConverter 3.0.0
> using GTK version: 3.0
> using Gstreamer version: 1.14.5.0
> using gio
> "faac" gstreamer element not found, disabling AAC output.
> /usr/share/soundconverter/python/soundconverter/ui.py:1406: Warning:
> g_value_type_transformable: assertion 'G_TYPE_IS_VALUE (src_type)' failed
> builder.add_from_file(gladefile)
>
> (python3:21617): Gtk-WARNING **: 23:36:12.770:
> ../../../../gtk/gtkliststore.c:836: Unable to convert from (null) to
> gchararray
> adding: 0 files
> Added 0 files in 0.00s (scan 0.00s, add 0.00s)
>
>
> running on Linux Mint 19.3 Cinnamon
>
> checking the tags with kid3 showed them present and correct, created
> by asunder, which also created the appropriate directory structure
> artist/album/...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/soundconverter/+bug/1863048/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers