folder drag and drop includes non-media files

Bug #1767163 reported by s0nspark on 2018-04-26
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
SoundConverter
Wishlist
GautierPortet

Bug Description

v3.0.0 on Arch Linux

With the latest release when I open a folder with SoundCOnverter or drag and drop a folder from Nautilus onto the window, SoundConverter picks up non-media files. It did not use to do this - it would only include multimedia files in the list.

Also, I notice I am not able to remove single files from the list - clicking delete clears the list.

Thanks for any help!

GautierPortet (kassoulet) wrote :

This is a new optimization of version 3: not detecting each file type before adding.
We may need to find a way to add a basic filtering there.

Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
importance: Undecided → Wishlist
status: New → Confirmed
Changed in soundconverter:
milestone: none → 3.0.1
status: Confirmed → Triaged
Hoola Hoop (djme) wrote :

Hopefully this one gets fixed soon.

Despite being an intended optimization, the lack of a media file filter check is a huge hindrance. With Soundconverter now including items such as folder.jpg etc. in the batch conversion, gstreamer hangs when such an item is encountered and basically pauses the entire conversion process until the error is acknowledged.

Changed in soundconverter:
status: Triaged → In Progress
GautierPortet (kassoulet) wrote :

This should do it:
https://github.com/kassoulet/soundconverter/commit/7d4aad9bfe78ff31c50ef6ccfa76d9edef45b6eb

After adding back the typefinder, it was obvious that it was waaaay too slow to be back for real.

So, a first pass is done on the files to determine the mime type of each file extension. This way we support everything, without real speed decrease.

Changed in soundconverter:
status: In Progress → Fix Committed
Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers