Ubuntu17.10/version:3.0.0-beta1: converting Flac to MP3: all tags are gone

Bug #1732807 reported by Jay Viper on 2017-11-17
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
SoundConverter
Undecided
GautierPortet
soundconverter (Ubuntu)
Undecided
Unassigned

Bug Description

So I encoded 69 Flac files to Mp3 (VBR setting - normal quality). I then viewed the tags of the output MP3 files using puddletag and all tags (track, album, artist and etc) are all gone.

As another test, I converted the same 69 Flac files to ogg and no issues with the tag. They are all there.

I installed the app via the official Ubuntu repo.

Thanks

edit: I've experienced this on my desktop/laptop. I've tried 16.04 and 17.10 on both machines. Same results. I believe on 16.04, I got version 2.x

Jay Viper (mrjayviper) on 2017-11-17
description: updated
description: updated
s56vpe (peter-podbevsek) wrote :

Same thing on 18.04. Soundconverter version 3.0.0.

Found this in debug output:
"id3mux" gstreamer element not found, disabling MP3 tags output.

The id3mux element is found in gst-plugins-bad. Should probably make gstreamer1.0-plugins-bad a dependency on bionic. Installing the package manually fixes the problem.

Changed in soundconverter:
status: New → Confirmed
Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in soundconverter (Ubuntu):
status: New → Confirmed
Bill Crocker (willc9) wrote :

Unfamiliar with this system not sure where this is up to. If fixed version available please advise where to get it.

Downloaded SoundConverter using "sudo apt-get install soundconverter" onto dual boot HP laptop running Linux Mint 18.0, so using SoundConverter version shown in 1st image in attachment.

Want to convert 100s of flac to mp3. Most tags converted ok, but Year, and main tags I need: Grouping and Rating, are missing from mp3 files as shown in 2nd image.

As a test tried ogg conversion and all tags converted ok as 3rd image.

GautierPortet (kassoulet) wrote :

The tags copied are checked against an allowlist to remove unwanted tags.
So this behaviour is by design.

Bill Crocker (willc9) wrote :

Thanks for response. As a newbie I'd appreciate advice on how to modify this allowlist - searched for a file including that name, no result.

Bill Crocker (willc9) wrote :

Thank you for this advice. I may have done this wrong - see attached file - but added 'rating', and 'grouping', to append_tag list and neither Rating nor Grouping have a tag value in the converted mp3 files in my testing.

I've noticed that the tag 'year' was already included in the source your link points to, but this is one of the 3 tags missed in flac => mp3 conversions that are in the Mp3 examples I sent with my first inquiry above.

Is it possible to follow how the flac => ogg conversions are correctly converting all tags?

GautierPortet (kassoulet) wrote :

To disable tag filtering, change:

        if tag not in tag_whitelist:
            return

Into:
        #if tag not in tag_whitelist:
        # return

Or remove both lines.

Bill Crocker (willc9) wrote :

Thanks for the response - I do appreciate you're sticking with this bug.

Unfortunately the result is the same: no conversion of the same tags as per attached. Since the year tag has never been converted in all tests I've done, does it suggest the tags that are converted like artist, track, album, length, genre, are being set somewhere else? Is it useful to note the format change of the track tag from 1 to 1/10; where is that being done?

Jay Viper (mrjayviper) wrote :

I appreciate the responses dev. But I am wondering why conversion to OGG doesn't seem to be limited what the "tag_whitelist" settings while it is limited in MP3.

I understand that the tag_whitelist can be edited but seems reasonable to expect that common tags like track number/name, album and artist would at least be automatically allowed.

sezanzeb (sezanzeb) wrote :

I think the tag_whitelist - and therefore the tags stored in our "sound_file" objects - is only important for constructing the path based on a pattern like {artist}. Tags are copied in gstreamer and we don't have control over that.

Please check if the Year tag is missing using ffprobe. I had cases of m4a tags not being displayed in various tools. That may help to further narrow down the problem.

And maybe we should use some sort of tag library to copy tags instead. Like mutagen. Unfortunately mutagen was the package for tag reading in those tools that didn't display my m4a tags...

Bill Crocker (willc9) wrote :

Thanks for responding. I apologise for an error in my comments above. The Year tag has in all cases been correctly included in the converted file. My problem is that Grouping and Rating are not included in mp3 conversions.

As a newbie I'm not following your design comments, but as suggested I've attached screen shots of ffprobe results for both a sample mp3 file and the same track as an ogg conversion, which includes the Rating and Grouping tags and some variants of these tags.

Can mp3 files use the same processing as ogg ones?

Bill Crocker (willc9) wrote :

Sending mp3 ffprobe result

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers