Can't convert files with single quotes - ' - in the name

Bug #1623315 reported by Adam Williamson on 2016-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Critical
GautierPortet

Bug Description

I've seen several fixes to 'problematic' file names, like https://github.com/kassoulet/soundconverter/commit/d73d05b25d168c8db5520f80da406f38d8c2f8df and https://github.com/kassoulet/soundconverter/commit/3a17d980bee5e87de6e6d8675076960600d8e297 , but I think it's still not quite right: I get an error on any file with a ' in the name. e.g.:

Could not open resource for writing. (Fully Completely (remastered deluxe edition) (Disc 1 of 2)/07 - We'll Go Too.flac)

files from the same album without a ' in their name convert fine. I've tried with the latest git (and also with 2.1.6).

Adam Williamson (awilliamson) wrote :

You get a slightly different error when writing the file, if you rename the source file: "Invalid parameters".

Changed in soundconverter:
importance: Undecided → Critical
assignee: nobody → GautierPortet (kassoulet)
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers