SoundConverter can't export to a folder on an MTP device

Bug #1339836 reported by François Guerraz on 2014-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
High
GautierPortet

Bug Description

See this downstream bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1109494

Description of problem:
SoundConverter can't export to a folder on an MTP device

How reproducible:
All the time

Steps to Reproduce:
1. Choose files to convert
2. Select a folder on an MTP device mounted in Nautilus as a destination
3. Start the export.

Actual results:
Progress bar stays on "Preparing Conversion..."

Expected results:
Should convert the files and save them in the selected location.

In fileoperations.py filename_to_uri() crashes in gnomevfs.URI(), which is the API from package gnome-python2-gnomevfs (in bugzilla: gnome-python2). It does not accept the "mtp://" prefix at all,

http://bazaar.launchpad.net/~kassoulet/soundconverter/main/view/head:/soundconverter/ui.py#L1180

Sets the gtk file chooser to be "local only" (use_gnomevfs is set to false in fileoperations.py) and according to the doc:

http://www.pygtk.org/pygtk2reference/class-gtkfilechooser.html#method-gtkfilechooser--set-local-only

which is specifically to make sure that "selected files are guaranteed to be accessible through the operating system's native file system.

But then SoundConverter bothers with URIs.

GautierPortet (kassoulet) wrote :

Historically, gnomevfs support was added, to support non-local file-systems. Due to numerous problems when switching to Gio, the support is now disabled, and the file chooser should use local file-systems only.
The problem here being that the output folder chooser is not local-only.

Changed in soundconverter:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → GautierPortet (kassoulet)
GautierPortet (kassoulet) wrote :
Changed in soundconverter:
status: Confirmed → Fix Committed
milestone: none → 2.1.4
François Guerraz (kubrick) wrote :

Hi,

Thanks for the quick fix. It's better, it doesn't crash. But it still allows to select an MTP device and fails to write to it with the attached error message.

Regards,

François.

Changed in soundconverter:
status: Fix Committed → In Progress
Changed in soundconverter:
status: In Progress → Fix Committed
Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments