2.0.4: GStreamer encountered a general stream error

Bug #1328202 reported by Vincent on 2014-06-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Undecided
Unassigned

Bug Description

This bug happen when trying to convert a FLAC in MP3, and generate a 0 octet file. See attachement sample. I'm using the 2.0.4.

Vincent (influence-pc) wrote :
Michael Schwendt (mschwendt) wrote :

Not reproducible with Soundconverter 2.1.3 (Fedora 13 x86_64).

Here are a few observations:

Soundconverter 2.0.4 is not really usable without applying lots of bug-fixes. A rather large patch can be found at
http://pkgs.fedoraproject.org/cgit/soundconverter.git/plain/soundconverter-2.0.4-fedora.patch?h=f19 and will make it work very well.

> GStreamer encountered a general stream error

Soundconverter uses GStreamer as a backend for decoding and encoding. Problems while converting from FLAC to MP3, for example, could also be due to a problem in the used GStreamer codecs. But this is difficult to tell when you still use Soundconverter 2.0.4, especially when it's not patched at all.

Consider upgrading to Soundconverter 2.1.3, which is a lot better than 2.0.4 unpatched.

summary: - GStreamer encountered a general stream error
+ 2.0.4: GStreamer encountered a general stream error
lykeion (lykeion2003) wrote :

Got the exact same bug when trying to convert FLAC to OGG using Soundconverter 2.0.4.
When I tried with a later version of Soundconverter (2.1.4) the conversion went fine.

I wish the Ubuntu Trusty repository could update to a later version of Soundconverter, instead of the buggy 2.0.4 version release from 2012-10-07 <https://launchpad.net/soundconverter/trunk/2.0.4>

DooMMasteR (winrootkit) wrote :

I only have problems with 24bit FLAC files, 16bit resolution works just fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers