fileoperations.py:58:vfs_walk:AccessDeniedError: Access denied

Bug #1293517 reported by Michael Schwendt on 2014-03-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Critical
GautierPortet

Bug Description

Here's a strange one where the exception handling is present, but comes too early and hence is incomplete (full bug report and my NEEDINFO query at https://bugzilla.redhat.com/1077005 ):

Traceback (most recent call last):
  File "/usr/lib/soundconverter/python/soundconverter/ui.py", line 1280, in on_addfolder_activate
    self.filelist.add_uris(folders, extensions=extensions)
  File "/usr/lib/soundconverter/python/soundconverter/ui.py", line 230, in add_uris
    filelist = vfs_walk(gnomevfs.URI(uri))
  File "/usr/lib/soundconverter/python/soundconverter/fileoperations.py", line 65, in vfs_walk
    vfs_walk(uri.append_path(file_info.name)))
  File "/usr/lib/soundconverter/python/soundconverter/fileoperations.py", line 65, in vfs_walk
    vfs_walk(uri.append_path(file_info.name)))
  File "/usr/lib/soundconverter/python/soundconverter/fileoperations.py", line 65, in vfs_walk
    vfs_walk(uri.append_path(file_info.name)))
  File "/usr/lib/soundconverter/python/soundconverter/fileoperations.py", line 65, in vfs_walk
    vfs_walk(uri.append_path(file_info.name)))
  File "/usr/lib/soundconverter/python/soundconverter/fileoperations.py", line 65, in vfs_walk
    vfs_walk(uri.append_path(file_info.name)))
  File "/usr/lib/soundconverter/python/soundconverter/fileoperations.py", line 58, in vfs_walk
    for file_info in dirlist:
AccessDeniedError: Access denied

Local variables in innermost frame:
dirlist: <gnomevfs.DirectoryHandle object at 0x11a2c48>
uri: <gnomevfs.URI 'file:///home/wrnash/smb4k/HOMESERVER/allusers/Pictures/Wolf%20tour/'>
filelist: []

Changed in soundconverter:
importance: Undecided → Critical
assignee: nobody → GautierPortet (kassoulet)
GautierPortet (kassoulet) wrote :

This is stange. Has you said, the check is already here.
The folder is on a smb share, maybe some funky exception is raised?

I'll expand the exception, but it's dificult to be sure if this will do it, since I can't reproduce.

GautierPortet (kassoulet) wrote :
Changed in soundconverter:
status: New → Fix Committed
milestone: none → 2.1.3
Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers