Add support for gstreamer 1.0

Bug #1206668 reported by Ivo Anjo on 2013-07-30
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
SoundConverter
Wishlist
GautierPortet
openSUSE
Unknown
Unknown

Bug Description

Gstreamer 1.0 can already be installed in parallel with 0.10, and has many bug fixes (such as fixed alac to flac, and ape decoding).

It would be nice if the gstreamer version used was selectable, or just changed to 1.0 altogether.

Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
status: New → Confirmed
importance: Undecided → Wishlist
Changed in soundconverter:
milestone: none → 2.2
status: Confirmed → In Progress
Sebastian Dröge (slomo) wrote :

Is this code in a branch somewhere already, and also done together with porting to python-gi / GTK3?

GautierPortet (kassoulet) wrote :

It's here: https://github.com/kassoulet/soundconverter/tree/py3k - (very experimental)

And yes, it's the full monty: Python3 + GTK3 + GStreamer 1.0

Sebastian Dröge (slomo) wrote :

Great, thanks :)

adam777 (adam777) wrote :

Hi,
Just found out about this.
Any plans on mainlining this branch soon?

GautierPortet (kassoulet) wrote :

There still some work to do before it can be released.
And I don't have enough time these days...

adam777 (adam777) wrote :

Fair enough.
Thanks for your quick reply.

Braiam Peguero (braiampe) wrote :

Is there a roadmap or TODO that can be followed to help?

GautierPortet (kassoulet) wrote :

first alpha release:
https://launchpad.net/soundconverter/3.x

let's finish this!

Changed in soundconverter:
milestone: 2.2 → 3.0.0-beta1
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.