2.1.0: The file that triggers plugin installation doesn't get converted

Bug #1163597 reported by Michael Schwendt on 2013-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
High
GautierPortet

Bug Description

Fully reproducible with Fedora 19 Alpha TC2. Steps to reproduce:

1. Erase gstreamer-plugins-ugly to remove MP3 decoder.
2. Use "Add Folder" to add a folder with e.g. 10 MP3 files.
3. Start conversion.

What happens?

4. The plugin installation dialog pops up. Searching leads to installing gstreamer-plugins-ugly.
5. Conversion process starts finally, but for one file the progress doesn't advance.
6. The file that triggered plugin installation doesn't get converted.
7. Conversion doesn't stop. ETA increases slowly. The file's temporary output file exists with zero size, but doesn't
get renamed.

Michael Schwendt (mschwendt) wrote :
Michael Schwendt (mschwendt) wrote :

Attached is the "soundconverter -d" output where the file "Instant Remedy - Commando.mp3" doesn't get converted.

Michael Schwendt (mschwendt) wrote :

If I "Limit number of parallel jobs" to 1, the problem is not reproducible.

Changed in soundconverter:
importance: Undecided → High
milestone: none → 2.1.1
assignee: nobody → GautierPortet (kassoulet)
status: New → Confirmed
Changed in soundconverter:
status: Confirmed → Fix Committed
Changed in soundconverter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers