ape files are not being converted

Bug #1127621 reported by Gregory House
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
SoundConverter
Medium
GautierPortet

Bug Description

soundconverter fails to convert an .ape file to anything. the console output says:
(soundconverter:6548): GStreamer-CRITICAL **: _gst_util_uint64_scale: assertion `denom != 0' failed
any other soft that interferes with gstreamer libs works just fine.

Revision history for this message
GautierPortet (kassoulet) wrote :

Can you detail the version of soundconverter and gstreamer please?

Changed in soundconverter:
assignee: nobody → GautierPortet (kassoulet)
importance: Undecided → Medium
Revision history for this message
Gregory House (bronetemkinponosec) wrote :

I've tried using soundconverter both 2.0.2 from mint repositories and 2.0.4 from sources from official cite, both are making the same mistake. both versions are using gstreamer0.10 - based libraries, as far as I refer to "apt-cache show soundconverter" output. these versions are indeed have been installed before apt could have installed soundconverter, and all the depencies have been solved.

Revision history for this message
Michael Schwendt (mschwendt) wrote :

Works here with 2.0.4 including the recent patch-o-mania, however, and gstreamer-ffmpeg. Hence the pipeline that is used, is different from Soundconverter 2.0.2 and 2.0.4 unpatched:

gst-lauch-0.10 giosrc location="file:///home/personal/Music/test/ape/01.ape" name=src ! decodebin name=decoder ! audiorate ! audioconvert ! audioresample ! vorbisenc quality=0.6 ! oggmux ! giosink location="file:///home/ms18/tmp/01.ogg"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers