1.5.4 / AAC / Cannot create pipeline

Bug #1048917 reported by Rae Andrea Moses on 2012-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
SoundConverter
Undecided
Unassigned

Bug Description

When converting to AAC I get the error message.

"Gstreamer error when creating pipeline
no element "faac""

 I'm using version 1.5.4 in Ubuntu 12.04 and I have faac installed, along with libfaac0 and even libfaac-dev but nothing makes the error message go away.

Michael Schwendt (mschwendt) wrote :

Which GStreamer plug-in packages do you have installed? Also check the output of "gst-inspect|grep aac". The error refers to the GStreamer plug-in libgstfaac.so

Rae Andrea Moses (cobigelow) wrote :

I reinstalled before I thought to check back here and still no changes. I have the base set, the nice set, the good, the bad and the ugly set. I also have the ffmpeg, the alsa, pulseaudio, X11, pango and the gconf plugins. I hope that's what you mean, if there are any hidden ones I can't see from synaptic then I'm not really sure. The output was:

ffmpeg: ffmux_adts: FFmpeg ADTS AAC muxer (not recommended, use aacparse instead)
ffmpeg: ffdec_aac_latm: FFmpeg AAC LATM (Advanced Audio Codec LATM syntax) decoder
ffmpeg: ffdec_aac: FFmpeg Advanced Audio Coding decoder
ffmpeg: ffenc_aac: FFmpeg Advanced Audio Coding encoder
typefindfunctions: audio/aac: aac, adts, adif, loas
audioparsers: aacparse: AAC audio stream parser
voaacenc: voaacenc: AAC audio encoder

GautierPortet (kassoulet) wrote :

Michael is right, you need the GStreamer faac plugin.
Which linux distribution are you using?

Rae Andrea Moses (cobigelow) wrote :

Ubuntu 12.04. And I'm pretty sure I have faac installed already, but i could be wrong

GautierPortet (kassoulet) wrote :

Gstreamer's faac plugin is not installed. or it would show up in gst-inspect:

$ gst-inspect | grep faac
faac: AAC audio encoder

GautierPortet (kassoulet) wrote :

And in Ubuntu, the package to install is: gstreamer0.10-plugins-bad-multiverse

Rae Andrea Moses (cobigelow) wrote :

I have that installed, should I install the gdb also?

summary: - Cannot create pipeline
+ 1.5.4 / AAC / Cannot create pipeline
Ilan (ilan) on 2014-01-17
information type: Public → Public Security
information type: Public Security → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers