gpg should use port 443 by default in order to work from behind firewalls

Bug #615788 reported by Sorin Sbarnea on 2010-08-10
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Undecided
Unassigned
Software Properties
In Progress
Medium
Unassigned
Ubuntu Website - OBSOLETE
Undecided
Unassigned

Bug Description

In most corporate environments the only ports available are 80 8080 3128 and 443.

gpg should use a safer port (443) in order to be able to install the keys,

https://answers.launchpad.net/launchpad/+question/79193

Curtis Hovey (sinzui) on 2010-08-10
affects: launchpad → ubuntu-website
Sorin Sbarnea (ssbarnea) wrote :

It looks that ubuntu keyserver is already using the port 80 so people can do:

gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 0A5174AF

gpg will not use the port 80 if you do not specify the full URI, like in example.

Sorin Sbarnea (ssbarnea) wrote :

Now that port 80 works we can consider this issue solved.

Changed in ubuntu-website:
status: New → Fix Released
Martin Spacek (mspacek) on 2010-11-30
Changed in launchpad:
status: New → Confirmed
Martin Spacek (mspacek) wrote :

I think this should be reopened (I don't have permissions to reopen the original bug for ubuntu-website, so I reopened for launchpad instead - sorry for the hassle). This issue is not solved. The issue is that the *default* port 11371 used for the keyserver is blocked in most corporate environments (like mine). Furthermore, the error messages from Synaptic and add-apt-repository are a fairly generic "can't retrieve repository key" and "can't connect to keyserver" respectively (I'm paraphrasing). This is bad. All these problems could be fixed by changing the default to something less likely to be blocked, like 443, or perhaps 80. Now that I think about it, this would not only have to happen on the server side (which has already happened for port 80), but also on the client side. Maybe apt and/or synaptic should be added to this bug?

Ian Booth (wallyworld) on 2010-11-30
Changed in launchpad:
status: Confirmed → Opinion
Ian Booth (wallyworld) wrote :

I have opened a new bug 682995 to request that the Launchpad gpg port be changed. This bug should remain Fixed.

Changed in launchpad:
status: Opinion → Invalid
Changed in synaptic:
status: New → Invalid
Gary Poster (gary) wrote :

I changed the synaptic status because I changed the bug mentioned above (bug 682995) to Won't Fix for Launchpad. I don't think that will accomplish anything useful. As I understand it, and as reinforced there, the person filing the bugs thinks that this should be addressed in synaptic and possibly other programs to give a more informative error message. I am afraid that this may need to happen at an even lower level, but I don't see a specific response to the synaptic aspect of this bug here. If the synaptic aspect of this bug should in fact be closed, perhaps a new one should be opened (and perhaps in another project).

Changed in synaptic:
status: Invalid → New
Michael Vogt (mvo) on 2010-12-13
affects: synaptic → software-properties
Changed in software-properties:
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → In Progress
Alin Andrei (nilarimogard) wrote :

This was marked as fixed in software-properties 0.78.1 in Natty: https://launchpad.net/ubuntu/natty/+source/software-properties/0.78.1

Any chance it will be backported to Lucid/Maverick?

Brian Murray (brian-murray) wrote :

The fix is only for PPAs as far as I can tell.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions