NoDistroTemplateException during upgrade from 13.10 to 14.04

Bug #1313991 reported by Michael Heuberger on 2014-04-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Software Properties
New
Undecided
Unassigned

Bug Description

I tried a `do-release-upgrade` from 13.10 to 14.04 today and it failed in the middle :(

There are still files, libraries and modules left from 13.10 and newer files for 14.04 but Ubuntu still says it's version 13.10. At the moment my machine is somewhat in a limbo ...

I always see this message whenever I try to `apt-get update`:
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

So, I tried tried `sudo dpkg --configure -a` of course but then it becomes worse. Toward the end I see these lines and then, bang, whole system becomes frozen, unresponsible:

Checking init scripts
Nothing to restart

- BANG! Frozen from here.

Had to cold restart, then tried this over and over again, multiple times. Always the same result. Unable to continue the upgrade to Ubuntu 14.04

Can anybody help me please? I need my machine badly for my work. Thanks!

In this thread you'll find a lot more information about my problem:
https://answers.launchpad.net/ubuntu/+question/247836

Please read this link before you proceed.

Again, Whoopsie log files have shown that a NoDistroTemplateException is thrown and might be the cause for panicking my machine.

Thanks!

Should I edit /etc/lsb-release and enter a different content so that the exception is not thrown anymore?

description: updated
affects: ubuntu → software-properties
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions