Sofware center core dumping shortly after launch in fresh 13.04 install

Bug #1179462 reported by Ian Dickinson on 2013-05-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
New
Undecided
Unassigned

Bug Description

I've just installed 13.04 on a Sony Vaio laptop. Since installing, the only things I've done are:

* update
* install gnome3
* install synaptic

When I try to launch the software centre, the window appears but the application crashes after about 5 seconds. Running from the terminal, this is what I see:

$ software-center
2013-05-13 12:44:31,061 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-05-13 12:44:31,532 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-05-13 12:44:31,537 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-05-13 12:44:31,544 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-05-13 12:44:31,543 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-05-13 12:44:31,582 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-05-13 12:44:33,294 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'steam-launcher'' not available
2013-05-13 12:44:33,294 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'motorbike'' not available
2013-05-13 12:44:33,294 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'screencloud'' not available

(software-center:8511): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2296 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

I've tried the "rm -r ~/.cache/software-center" fix suggested on AskUbuntu, but it makes no difference.

JaSauders (jasauders) wrote :

I'm having the same issue.

Ubuntu GNOME 13.04 64 bit. Gnome 3 PPA enabled. Fully updated, 3.8.0-26 kernel. Fully updated as of July 7th 2013. I haven't been able to open the software center for quite a while now, but I've just ignored it, however it's wearing on me now.

Some things I tried:

http://paste.ubuntu.com/5852888/
http://paste.ubuntu.com/5852894/
http://paste.ubuntu.com/5852904/

All did nothing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers